summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-25 10:10:56 -0400
committerSam James <sam@gentoo.org>2021-05-09 04:42:10 +0000
commit65f946a1562737200e56551362f5998293e2b2a9 (patch)
treecf6417836d8b43d77a08962832a57b8758a35f1b /dev-libs/trio
parentlicenses: add trio for dev-libs/trio (diff)
downloadgentoo-65f946a1562737200e56551362f5998293e2b2a9.tar.gz
gentoo-65f946a1562737200e56551362f5998293e2b2a9.tar.bz2
gentoo-65f946a1562737200e56551362f5998293e2b2a9.zip
dev-libs/trio: initial import
needed to unbundle trio from games-emulation/mednafen Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/trio')
-rw-r--r--dev-libs/trio/Manifest1
-rw-r--r--dev-libs/trio/metadata.xml11
-rw-r--r--dev-libs/trio/trio-1.16.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/trio/Manifest b/dev-libs/trio/Manifest
new file mode 100644
index 000000000000..59ec71d46d41
--- /dev/null
+++ b/dev-libs/trio/Manifest
@@ -0,0 +1 @@
+DIST trio-1.16.tar.gz 167337 BLAKE2B 0f284e0a130723f7511c0e874276c79c1addc1329833d14f0b76bae9808d90b76a2b26817ee85da71c3997360918cb534917a11bbe35ba627d1012cd8a2f6299 SHA512 3a8bac3ed001f70f498bd2ab0881ed6d3760bc978bf9ff587c3fc1d5d7a38205f779c5fe445f41edaa9e23c15bc1b4a521916e19161277741bc8e2f744b46c69
diff --git a/dev-libs/trio/metadata.xml b/dev-libs/trio/metadata.xml
new file mode 100644
index 000000000000..c71b42fc85c6
--- /dev/null
+++ b/dev-libs/trio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ctrio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/trio/trio-1.16.ebuild b/dev-libs/trio/trio-1.16.ebuild
new file mode 100644
index 000000000000..1980624be416
--- /dev/null
+++ b/dev-libs/trio/trio-1.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="mirror://sourceforge/ctrio/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+HTML_DOCS=( html/. )
+
+src_prepare() {
+ default
+ sed -i '/$(CC)/s/-o/$(LOCAL_LDFLAGS) -o/' Makefile.in || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" LOCAL_LDFLAGS="${LDFLAGS}"
+ ln -s libtrio.so.2{.0.0,} || die
+ ln -s libtrio.so{.2.0.0,} || die
+}
+
+src_test() {
+ emake LOCAL_LDFLAGS="${LDFLAGS}" regression
+ LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ./regression || die
+}
+
+src_install() {
+ doheader trio*.h
+ dolib.so libtrio.so*
+ einstalldocs
+}