summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-27 16:07:33 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-27 16:13:54 +0000
commit7a89ddd17a5cee5991d3ee6596a0e9720e794750 (patch)
treef633bffa874bd117a458af89a53f76ab16ba1010 /dev-libs/tree-sitter
parentdev-util/tree-sitter-cli: init at 0.20.2 (diff)
downloadgentoo-7a89ddd17a5cee5991d3ee6596a0e9720e794750.tar.gz
gentoo-7a89ddd17a5cee5991d3ee6596a0e9720e794750.tar.bz2
gentoo-7a89ddd17a5cee5991d3ee6596a0e9720e794750.zip
dev-libs/tree-sitter: remove ts-cli USE flag
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-libs/tree-sitter')
-rw-r--r--dev-libs/tree-sitter/tree-sitter-0.20.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/tree-sitter/tree-sitter-0.20.2-r1.ebuild b/dev-libs/tree-sitter/tree-sitter-0.20.2-r1.ebuild
new file mode 100644
index 000000000000..9800235d12bc
--- /dev/null
+++ b/dev-libs/tree-sitter/tree-sitter-0.20.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Tree-sitter is a parser generator tool and an incremental parsing library"
+HOMEPAGE="https://github.com/tree-sitter/tree-sitter"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-No-static-libs-gentoo.patch" )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+}
+
+pkg_postinst() {
+ optfeature "building and testing grammars" dev-util/tree-sitter-cli
+}