summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/sord
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/sord')
-rw-r--r--dev-libs/sord/Manifest2
-rw-r--r--dev-libs/sord/metadata.xml5
-rw-r--r--dev-libs/sord/sord-0.12.0.ebuild42
-rw-r--r--dev-libs/sord/sord-0.12.2.ebuild42
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/sord/Manifest b/dev-libs/sord/Manifest
new file mode 100644
index 000000000000..400f670ef2d5
--- /dev/null
+++ b/dev-libs/sord/Manifest
@@ -0,0 +1,2 @@
+DIST sord-0.12.0.tar.bz2 285075 SHA256 126baa06480b6930f874e8c519d4168d8224f7a3203a49b287e24c6bfdf91cb8 SHA512 c24c82fd4d9f74d10923d0cf405d2eabbaabd66b3b11e29719115515edcd8ccbc4a32866ca510dc676ca6ca833b0d9c8ccf43d36f6b0ef010d0211cee821db02 WHIRLPOOL 76d392bd63270fc2c0cb19ce89fc5bc1cc0777ae230912d831ed74705df96d6b7528f36679e53f0d929825db9042592f88746a31af8d65ee187bcb40ae7d1a1c
+DIST sord-0.12.2.tar.bz2 303365 SHA256 bd0538d37de5e782023a7261d8ee9d83a792a12eeea7d94dec7a93dd9cda0767 SHA512 2906808138658f89cb6ab939c20e0a092180535629c75b1a0277648af18fb019055dd3cde53f57d7b0d635666be98848bed021ba0bd922a34cfaae3a98c66cbd WHIRLPOOL c731ceb92650b1af7ce4cb53bf209cfc632d74a204eae0b2ea1fcc1ccbca5564a22c83f6e746c1ad9761be4ec155b62cecc5fe90079dff613826d2e275a09df6
diff --git a/dev-libs/sord/metadata.xml b/dev-libs/sord/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/dev-libs/sord/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>
diff --git a/dev-libs/sord/sord-0.12.0.ebuild b/dev-libs/sord/sord-0.12.0.ebuild
new file mode 100644
index 000000000000..d831988d5535
--- /dev/null
+++ b/dev-libs/sord/sord-0.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}
diff --git a/dev-libs/sord/sord-0.12.2.ebuild b/dev-libs/sord/sord-0.12.2.ebuild
new file mode 100644
index 000000000000..d831988d5535
--- /dev/null
+++ b/dev-libs/sord/sord-0.12.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}