summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/pslib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/pslib/files')
-rw-r--r--dev-libs/pslib/files/pslib-getline.patch47
-rw-r--r--dev-libs/pslib/files/pslib-lm.patch11
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/pslib/files/pslib-getline.patch b/dev-libs/pslib/files/pslib-getline.patch
new file mode 100644
index 000000000000..cfe7ce4da732
--- /dev/null
+++ b/dev-libs/pslib/files/pslib-getline.patch
@@ -0,0 +1,47 @@
+--- src/ps_afm.c 2007-07-11 20:18:00.000000000 +0200
++++ src/ps_afm.c.fix 2009-07-11 14:51:05.000000000 +0200
+@@ -138,7 +138,7 @@
+ return (int)(acc>=0? floor(acc+0.5) : ceil(acc-0.5) ) ;
+ }
+
+-static int getline(FILE *afmin) {
++static int pslib_getline(FILE *afmin) {
+ char *p ;
+ int c ;
+
+@@ -616,7 +616,7 @@
+ return(-1);
+ }
+
+- while (getline(fp)) {
++ while (pslib_getline(fp)) {
+ switch(interest(paramstring())) {
+ case N:
+ handleprotusion(psdoc, metrics) ;
+@@ -664,7 +664,7 @@
+ /*
+ * Read file line by line.
+ */
+- while (getline(metric->afmin)) {
++ while (pslib_getline(metric->afmin)) {
+ switch(interest(paramstring())) {
+ case FontName:
+ metric->fontname = paramnewstring(psdoc) ;
+@@ -1039,7 +1039,7 @@
+
+ while (1) {
+ while (param == NULL || *param == '\0') {
+- if (getline(metrics->afmin) == 0)
++ if (pslib_getline(metrics->afmin) == 0)
+ ps_error(psdoc, PS_RuntimeError, _("Premature end of encoding file."));
+ for (p=buffer; *p != '\0'; p++)
+ if (*p == '%') {
+@@ -1160,7 +1160,7 @@
+ psdoc->free(psdoc, e);
+ return -1;
+ }
+- while (getline(metrics->afmin)) {
++ while (pslib_getline(metrics->afmin)) {
+ for (p=buffer; *p != '\0'; p++)
+ if (*p == '%') {
+ if (ignoreligkern == 0)
diff --git a/dev-libs/pslib/files/pslib-lm.patch b/dev-libs/pslib/files/pslib-lm.patch
new file mode 100644
index 000000000000..46292eee3d4a
--- /dev/null
+++ b/dev-libs/pslib/files/pslib-lm.patch
@@ -0,0 +1,11 @@
+--- a/configure.in 2007-10-30 02:38:30.000000000 -0500
++++ b/configure.in 2009-01-21 18:55:37.000000000 -0600
+@@ -92,6 +92,8 @@
+ AC_SUBST(LIBHNJ_CFLAGS)
+ AC_SUBST(LIBHNJ_LIBS)
+
++AC_CHECK_LIB([m], [pow])
++
+ PNG_PREFIX=no
+ AC_ARG_WITH(png, [ --with-png=DIR Path to png library (/usr)])
+ case "${withval}" in