summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libowfat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/Manifest1
-rw-r--r--dev-libs/libowfat/files/libowfat-0.28-GNUmakefile.patch10
-rw-r--r--dev-libs/libowfat/libowfat-0.29.ebuild50
-rw-r--r--dev-libs/libowfat/metadata.xml10
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/libowfat/Manifest b/dev-libs/libowfat/Manifest
new file mode 100644
index 000000000000..ce62deddd019
--- /dev/null
+++ b/dev-libs/libowfat/Manifest
@@ -0,0 +1 @@
+DIST libowfat-0.29.tar.bz2 139489 SHA256 4badbdeed6bef4337f1edd6b86fb7154c5592509c272dcdc09c693161cbc6427 SHA512 35b3be01f288a24ebf01e1f860bc2bba7431db890be1b117f9a7f0702532610d283f6e569b1a1d1e625a4fec3394d2c6ed5c2bf512a11c38ecf89cf89ec72136 WHIRLPOOL cc23d2c0a643b6a65b5d07a555bb1bd32d5f5f572e1fe414725e28e51614c53f538e4c7a7a24022c10784ae8097714549624b5f548700970c8aa34ad3b926dfe
diff --git a/dev-libs/libowfat/files/libowfat-0.28-GNUmakefile.patch b/dev-libs/libowfat/files/libowfat-0.28-GNUmakefile.patch
new file mode 100644
index 000000000000..03b8981876d2
--- /dev/null
+++ b/dev-libs/libowfat/files/libowfat-0.28-GNUmakefile.patch
@@ -0,0 +1,10 @@
+--- GNUmakefile.bak 2011-10-22 22:08:53.443669478 -0700
++++ GNUmakefile 2011-10-22 22:09:27.535002311 -0700
+@@ -277,6 +277,7 @@
+ socket_accept4.o socket_accept6.o socket_connected.o socket_local4.o \
+ socket_local6.o socket_recv4.o socket_recv6.o socket_remote4.o \
+ socket_remote6.o: havesl.h
++socket_remote4.o: havescope.h
+
+ dns_nd6.o fmt_xlong.o scan_xlong.o fmt_ip6_flat.o $(TEXTCODE_OBJS): haveinline.h
+
diff --git a/dev-libs/libowfat/libowfat-0.29.ebuild b/dev-libs/libowfat/libowfat-0.29.ebuild
new file mode 100644
index 000000000000..dcaef4b07e25
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.29.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="diet"
+
+RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ # Required for mult/umult64.c to be usable
+ append-flags -fomit-frame-pointer
+}
+
+src_prepare() {
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET?=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ -i GNUmakefile || die "sed failed"
+ epatch "${FILESDIR}/libowfat-0.28-GNUmakefile.patch"
+}
+
+src_compile() {
+ emake -j1 \
+ CC=$(tc-getCC) \
+ $( use diet || echo 'DIET=' )
+}
+
+src_install () {
+ emake -j1 \
+ LIBDIR="${D}/usr/lib" \
+ MAN3DIR="${D}/usr/share/man/man3" \
+ INCLUDEDIR="${D}/usr/include/libowfat" \
+ install || die "emake install failed"
+
+ cd "${D}"/usr/share/man
+ mv man3/buffer.3 man3/owfat-buffer.3
+}
diff --git a/dev-libs/libowfat/metadata.xml b/dev-libs/libowfat/metadata.xml
new file mode 100644
index 000000000000..d6487d17b847
--- /dev/null
+++ b/dev-libs/libowfat/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+</maintainer>
+<longdescription>reimplement libdjb - excellent libraries from Dan Bernstein</longdescription>
+<use><flag name="diet">Compile against <pkg>dev-libs/dietlibc</pkg></flag></use>
+</pkgmetadata>