summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jline')
-rw-r--r--dev-java/jline/Manifest2
-rw-r--r--dev-java/jline/files/maven-build.properties13
-rw-r--r--dev-java/jline/files/maven-build.xml199
-rw-r--r--dev-java/jline/jline-1.0.ebuild58
-rw-r--r--dev-java/jline/jline-2.12.1.ebuild60
-rw-r--r--dev-java/jline/metadata.xml8
6 files changed, 340 insertions, 0 deletions
diff --git a/dev-java/jline/Manifest b/dev-java/jline/Manifest
new file mode 100644
index 000000000000..ddd6296356cb
--- /dev/null
+++ b/dev-java/jline/Manifest
@@ -0,0 +1,2 @@
+DIST jline-1.0.zip 463082 SHA256 761458d1541a44e678b3847917116a90001cf5cd22287c24c55dcf2c69ec73ca SHA512 2957e19a3536d89aeaf8f27afb1f8eb4eb8bcc99560244c7f1ba14693a84a2f5e677a6c21d5f85ec519674cc4cd6cb3c9e4725cb4797144168d2f6df3954aba9 WHIRLPOOL d80416660992a9fd6d13f350d7620556f46f48fe9071e939de555bbee35d3e68f6c6eee64ae18e03d826e8928987f4e2193bcf8fee1cb027a1a9791ca89c0cce
+DIST jline-2.12.1.tar.gz 97289 SHA256 41c03847f862c7eceb3c5b1cef9bc89f62db43c53f3328e46a6257bebcc7d68d SHA512 368492fa0b28e6aa3827db05d266b332935d9a03c2f6645d039941c61a698e85fd57accfac444503de4cb2f2dae5787496924b8d258faad1c18b6cafe787f99d WHIRLPOOL fdbebc7e16fadced5c0744be0175d47b3a0f12379c588f994d5870f685f421adeeb842192e0c14f855bf0a094ace4d11cb541397b19453324a1e6b031a3f5166
diff --git a/dev-java/jline/files/maven-build.properties b/dev-java/jline/files/maven-build.properties
new file mode 100644
index 000000000000..66ef7cf2840e
--- /dev/null
+++ b/dev-java/jline/files/maven-build.properties
@@ -0,0 +1,13 @@
+#Generated by Maven Ant Plugin - DO NOT EDIT THIS FILE!
+#Sun Jan 21 15:31:06 EET 2007
+maven.build.finalName=jline-0.9.9
+maven.build.outputDir=${maven.build.dir}/classes
+maven.build.resourceDir.0=src/main/resources
+maven.build.testResourceDir.0=src/test/resources
+maven.build.testOutputDir=${maven.build.dir}/test-classes
+maven.repo.local=lib
+maven.settings.offline=false
+maven.build.dir=target
+maven.settings.interactiveMode=true
+maven.build.srcDir.0=src/main/java
+maven.build.testDir.0=src/test/java
diff --git a/dev-java/jline/files/maven-build.xml b/dev-java/jline/files/maven-build.xml
new file mode 100644
index 000000000000..7be70998ddcc
--- /dev/null
+++ b/dev-java/jline/files/maven-build.xml
@@ -0,0 +1,199 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 1/21/07 3:31 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jline-from-maven" default="dist" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environnement properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jline-0.9.9"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/main/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+
+ <property name="maven.settings.offline" value="true"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <fileset dir="${maven.repo.local}">
+ <include name="*.jar"/>
+ </fileset>
+ </path>
+ <path id="build.test.classpath">
+ <fileset dir="${maven.repo.local}">
+ <include name="*.jar"/>
+ </fileset>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="junit-present, compile"
+ description="Compile the test code"
+ if="junit.present">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="junit-present, compile-tests"
+ if="junit.present"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="junit-present"
+ depends="test-junit-present"
+ unless="junit.present">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> Junit isn&apos;t present in your $ANT_HOME/lib directory. Tests not executed. </echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Dist target -->
+ <!-- ====================================================================== -->
+
+ <target name="dist" depends="package,test" description="Package the application and run tests"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/3.8.1"/>
+ <get src="http://jline.sourceforge.net/m2repo/junit/junit/3.8.1/junit-3.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
+ usetimestamp="true"
+ ignoreerrors="true"/>
+ <get src="http://repo1.maven.org/maven2/junit/junit/3.8.1/junit-3.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
+ usetimestamp="true"
+ ignoreerrors="true"/>
+ </target>
+</project>
diff --git a/dev-java/jline/jline-1.0.ebuild b/dev-java/jline/jline-1.0.ebuild
new file mode 100644
index 000000000000..41faa57e1609
--- /dev/null
+++ b/dev-java/jline/jline-1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java library for handling console input"
+HOMEPAGE="http://jline.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}/src"
+
+java_prepare() {
+ rm -fv "${WORKDIR}"/${P}/*.jar || die
+
+ # we don't support maven for building yet. this build.xml was generated by:
+ # - mvn ant:ant
+ # - tweak build.xml to not load properties from home dir
+ # - tweak the test target to match the test cases
+ # - change maven.repo.local from ~/.maven to "lib" in .properties
+ # - change classpath definitions to "*.jar"
+ cp "${FILESDIR}/maven-build.xml" build.xml || die
+ cp "${FILESDIR}/maven-build.properties" . || die
+ java-ant_ignore-system-classes
+
+ mkdir lib && cd lib || die
+ use test && java-pkg_jar-from --build-only junit
+}
+
+src_compile() {
+ # precompiled javadocs (needs maven to generate)
+ # -Dmaven.build.finalName is needed to override the one defined in the
+ # build.xml, which because it was generated with 0.9.9, defaults to
+ # jline-0.9.9 -nichoj
+ eant package -Dmaven.build.finalName=${P}
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -Djunit.present=true
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ #no api docs in this release
+ #use doc && java-pkg_dojavadoc ../apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/jline/jline-2.12.1.ebuild b/dev-java/jline/jline-2.12.1.ebuild
new file mode 100644
index 000000000000..a8372f325443
--- /dev/null
+++ b/dev-java/jline/jline-2.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for handling console input"
+HOMEPAGE="https://github.com/jline/jline2"
+SRC_URI="https://github.com/jline/jline2/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+CDEPEND="dev-java/jansi:1.11
+ dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5
+ test? ( dev-java/junit:4 )"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${PN}2-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="jansi-1.11,jansi-native"
+
+java_prepare() {
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+
+ # Don't forget the resources!
+ mkdir -p target/classes || die
+ cp -r src/main/resources/* target/classes || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ dodoc {CHANGELOG,README}.md
+}
+
+src_test() {
+ cd src/test/java || die
+
+ local CP=".:../resources:${S}/${PN}.jar:$(java-pkg_getjars junit-4,${JAVA_GENTOO_CLASSPATH})"
+ local TESTS=$(find * -name "*Test.java")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
diff --git a/dev-java/jline/metadata.xml b/dev-java/jline/metadata.xml
new file mode 100644
index 000000000000..dd088ba5da47
--- /dev/null
+++ b/dev-java/jline/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jline/jline2</remote-id>
+ </upstream>
+</pkgmetadata>