summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-15 16:18:16 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-15 16:30:19 +0100
commit6f34e4fe81c9db2863c743172da047db849a6f75 (patch)
treecbc57dcebd325abaf76aaa799f3713b5e14fedc3 /dev-java/jal
parentdev-python/mpi4py: Remove old (diff)
downloadgentoo-6f34e4fe81c9db2863c743172da047db849a6f75.tar.gz
gentoo-6f34e4fe81c9db2863c743172da047db849a6f75.tar.bz2
gentoo-6f34e4fe81c9db2863c743172da047db849a6f75.zip
dev-java/jal: EAPI 8, min java 1.8:*
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24198 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-java/jal')
-rw-r--r--dev-java/jal/jal-20031117-r6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/jal/jal-20031117-r6.ebuild b/dev-java/jal/jal-20031117-r6.ebuild
new file mode 100644
index 000000000000..18a84199c4ae
--- /dev/null
+++ b/dev-java/jal/jal-20031117-r6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Partial port of the C++ Standard Template Library"
+HOMEPAGE="http://vigna.dsi.unimi.it/jal"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CP_DEPEND="dev-java/ant-core:0"
+
+RDEPEND="
+ ${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CP_DEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/jal"
+
+src_prepare() {
+ default
+
+ # Generate sources.
+ ./instantiate -n byte bytes || die
+ ./instantiate -n short shorts || die
+ ./instantiate -n char chars || die
+ ./instantiate -n int ints || die
+ ./instantiate -n long longs || die
+ ./instantiate -n float floats || die
+ ./instantiate -n double doubles || die
+ ./instantiate Object objects || die
+ ./instantiate String strings || die
+
+ mkdir -p src/jal || die
+ mv bytes shorts chars ints longs floats doubles objects strings src/jal || die
+}