summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/charva/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/charva/files')
-rw-r--r--dev-java/charva/files/charva-respect-flags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/charva/files/charva-respect-flags.patch b/dev-java/charva/files/charva-respect-flags.patch
new file mode 100644
index 000000000000..73d09e9a265e
--- /dev/null
+++ b/dev-java/charva/files/charva-respect-flags.patch
@@ -0,0 +1,27 @@
+--- c/src/Makefile.linux.txt
++++ c/src/Makefile.linux.txt
+@@ -5,14 +5,14 @@
+ SHARED_OBJECT_EXT = so
+ TARGET = libTerminal.${SHARED_OBJECT_EXT}
+
+-CC = gcc
++CC ?= gcc
+ # "-D_USE_NCURSESW" was added for handling UTF-8 characters (contributed by Leos Urban)
+-CFLAGS = -fpic -shared -D_USE_NCURSESW_
++CFLAGS += -fpic -shared -D_USE_NCURSESW_
+
+ # The file "jni.h" is in ${JAVA_HOME}/include
+ # The file "jni_md.h" (included from jni.h) contains machine-dependent
+ # type definitions and is in ${JAVA_HOME}/include/${OS}
+-INCLUDES = -I${JAVA_HOME}/include -I${JAVA_HOME}/include/${OS} -I../include
++INCLUDES ?= -I${JAVA_HOME}/include -I${JAVA_HOME}/include/${OS} -I../include
+
+ # Changed "-lncurses" to "-lncursesw" (Leos Urban)
+ LIBS = -lncursesw
+@@ -21,5 +21,5 @@
+ all : ${TARGET}
+
+ ${TARGET} : Toolkit.c ../include/charva_awt_Toolkit.h Makefile.${OS}.txt
+- ${CC} ${CFLAGS} ${INCLUDES} Toolkit.c ${LIBS} -o ../lib/${TARGET}
++ ${CC} ${CFLAGS} ${LDFLAGS} ${INCLUDES} Toolkit.c ${LIBS} -o ../lib/${TARGET}
+