summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/quickcheck
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.6.ebuild2
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.7.6.ebuild2
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.1.ebuild2
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.2.ebuild2
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.9.2.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
index 3d43664927fa..d3f334016f07 100644
--- a/dev-haskell/quickcheck/quickcheck-2.6.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
@@ -13,7 +13,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
diff --git a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
index b9948c6f5c46..b25b97530d01 100644
--- a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
index 3dc8881d5cd9..5de1da2fac81 100644
--- a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
index 11b2fd9517ca..75fbf21a08fa 100644
--- a/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
diff --git a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
index d55efeea0daf..4a0ebf89f900 100644
--- a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"