summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:40 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:40 +0200
commit7982ab213bbfbb749ad6da8a19ed91b2525f3d1e (patch)
treefb35ba889cc288ce1fd86a6605cdf2b8ad40b395 /dev-cpp
parentdev-cpp/amqp-cpp: drop broken multilib, EAPI 8 (diff)
downloadgentoo-7982ab213bbfbb749ad6da8a19ed91b2525f3d1e.tar.gz
gentoo-7982ab213bbfbb749ad6da8a19ed91b2525f3d1e.tar.bz2
gentoo-7982ab213bbfbb749ad6da8a19ed91b2525f3d1e.zip
dev-cpp/argparse: add 2.6, tests
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/argparse/Manifest1
-rw-r--r--dev-cpp/argparse/argparse-2.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/argparse/Manifest b/dev-cpp/argparse/Manifest
index adac49660b31..ba65ae60a21d 100644
--- a/dev-cpp/argparse/Manifest
+++ b/dev-cpp/argparse/Manifest
@@ -1 +1,2 @@
DIST argparse-2.1.tar.gz 72452 BLAKE2B eece3f1cf6a2e58f5bec99f0223b31ba92147964053d98122099dd806a0ab62c6039ee8741281d1eca28b9d0e3aa02d7d076e8bcc64bbd5dd03c777f8e460531 SHA512 35746e0b526bd4406c954ab315f191abc57b08b48a047f108ddacc7baace406d3ddddb1af23d41caff565afecfeb41dfedd27a08cdba8d11b59dbe7c78b7e9b0
+DIST argparse-2.6.tar.gz 93865 BLAKE2B 5ab49a1e9d85e1252b4066fb3278b6c34c0e813f6b49063196cb294544a3adaf45930295834786d41ebbe483b4704be45e90e3a1d53e5085529e78e0b07fad0d SHA512 778e405b7790906794506a2175279465c7d7efa905d0848807fcbddf5ff827e9556a3f2660ee0207a70195a8e9e652ba37ba4df2a038d8646339525cec0f1784
diff --git a/dev-cpp/argparse/argparse-2.6.ebuild b/dev-cpp/argparse/argparse-2.6.ebuild
new file mode 100644
index 000000000000..e273fd49b506
--- /dev/null
+++ b/dev-cpp/argparse/argparse-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Argument Parser for Modern C++"
+HOMEPAGE="https://github.com/p-ranav/argparse"
+SRC_URI="https://github.com/p-ranav/argparse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DARGPARSE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ ./tests || die
+}