summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-03-14 20:23:02 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-03-14 20:23:23 -0600
commit5712f6efc74614ff4c324e881761669bfa75a5b5 (patch)
tree6ce2cb1d228f350cb928873dfe2b522dd387ae56 /dev-cpp/kokkos
parentapp-portage/repoman: Bump to version 2.3.21 (diff)
downloadgentoo-5712f6efc74614ff4c324e881761669bfa75a5b5.tar.gz
gentoo-5712f6efc74614ff4c324e881761669bfa75a5b5.tar.bz2
gentoo-5712f6efc74614ff4c324e881761669bfa75a5b5.zip
dev-cpp/kokkos: import from science overlay
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-cpp/kokkos')
-rw-r--r--dev-cpp/kokkos/Manifest1
-rw-r--r--dev-cpp/kokkos/kokkos-3.0.00.ebuild44
-rw-r--r--dev-cpp/kokkos/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/kokkos/Manifest b/dev-cpp/kokkos/Manifest
new file mode 100644
index 000000000000..44a82a67a70f
--- /dev/null
+++ b/dev-cpp/kokkos/Manifest
@@ -0,0 +1 @@
+DIST kokkos-3.0.00.tar.gz 1923287 BLAKE2B 4a2935e9388b3d577d6ce8678cad37830970222e6ce8a9c3db67633cb521440f14fdb380f03d3c77cd5ade85abe94aef97e9cc4949cc3a140fae958e0c15fff8 SHA512 c9daf62a2c92462c815aa241934aca5720bac8f88195635ae5a3ff4111d289a48898d32358b91e120756d3412820050297a76f44828f4cbc0b2b837a736e84aa
diff --git a/dev-cpp/kokkos/kokkos-3.0.00.ebuild b/dev-cpp/kokkos/kokkos-3.0.00.ebuild
new file mode 100644
index 000000000000..5c226a4e4b2f
--- /dev/null
+++ b/dev-cpp/kokkos/kokkos-3.0.00.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Kokkos C++ Performance Portability Programming EcoSystem"
+HOMEPAGE="https://github.com/kokkos"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+openmp test"
+
+DEPEND="
+ sys-apps/hwloc
+ "
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && \
+ use openmp && ! tc-has-openmp ; then
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/kokkos
+ -DKokkos_ENABLE_TESTS=$(usex test)
+ -DKokkos_ENABLE_AGGRESSIVE_VECTORIZATION=ON
+ -DKokkos_ENABLE_DEPRECATED_CODE=ON
+ -DKokkos_ENABLE_SERIAL=ON
+ -DKokkos_ENABLE_HWLOC=ON
+ -DKokkos_HWLOC_DIR="${EPREFIX}/usr"
+ -DKokkos_ENABLE_OPENMP=$(usex openmp)
+ -DBUILD_SHARED_LIBS=ON
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/kokkos/metadata.xml b/dev-cpp/kokkos/metadata.xml
new file mode 100644
index 000000000000..ef6b5dcd53aa
--- /dev/null
+++ b/dev-cpp/kokkos/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>