summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2020-07-02 21:00:29 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-07-19 13:43:26 +0300
commit05158bcdadf25405ccdcc97859ac4fcbb0d529b9 (patch)
tree21322bee00b2321cc9ecbbe98f8d18ec555b0fed /dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild
parentdev-cpp/gtest: Move PYTHON_DEPS to BDEPEND (diff)
downloadgentoo-05158bcdadf25405ccdcc97859ac4fcbb0d529b9.tar.gz
gentoo-05158bcdadf25405ccdcc97859ac4fcbb0d529b9.tar.bz2
gentoo-05158bcdadf25405ccdcc97859ac4fcbb0d529b9.zip
dev-cpp/gtest: Bump gtest-1.10.0_p20200702
Except for the occasional release, gtest now "lives at HEAD" like abseil. To maintain versioning consistency, take the base version from GOOGLETEST_VERSION in CMakeLists.txt and use _p instead of _pre. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild b/dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild
new file mode 100644
index 000000000000..560a1e282be2
--- /dev/null
+++ b/dev-cpp/gtest/gtest-1.10.0_p20200702.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python is required for tests and some build tasks.
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib python-any-r1
+
+GOOGLETEST_COMMIT=aee0f9d9b5b87796ee8a0ab26b7587ec30e8858e
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/googletest"
+else
+ if [[ -z ${GOOGLETEST_COMMIT} ]]; then
+ URI_PV=v${MY_PV:-${PV}}
+ else
+ URI_PV=${MY_PV:=${GOOGLETEST_COMMIT}}
+ fi
+ SRC_URI="https://github.com/google/googletest/archive/${URI_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}"/googletest-${MY_PV}
+fi
+
+DESCRIPTION="Google C++ Testing Framework"
+HOMEPAGE="https://github.com/google/googletest"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0_p20200702-increase-clone-stack-size.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e '/set(cxx_base_flags /s:-Werror::' \
+ googletest/cmake/internal_utils.cmake || die "sed failed!"
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_GMOCK=ON
+ -DINSTALL_GTEST=ON
+
+ # tests
+ -Dgmock_build_tests=$(usex test)
+ -Dgtest_build_tests=$(usex test)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use doc; then
+ docinto googletest
+ dodoc -r googletest/docs/.
+ docinto googlemock
+ dodoc -r googlemock/docs/.
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc googletest/samples/*.{cc,h}
+ fi
+}