summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-11 23:17:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-12 01:30:52 +0200
commitf860e052603993555d1094fc6d9d1f123c0a49fa (patch)
tree5218c33cde2f68efa945ecda52eccd1fe72a6dd3 /dev-cpp/cpp-httplib
parentgames-util/antimicrox: Stabilize 3.4.1 amd64, #939484 (diff)
downloadgentoo-f860e052603993555d1094fc6d9d1f123c0a49fa.tar.gz
gentoo-f860e052603993555d1094fc6d9d1f123c0a49fa.tar.bz2
gentoo-f860e052603993555d1094fc6d9d1f123c0a49fa.zip
dev-cpp/cpp-httplib: bump to 0.17.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-cpp/cpp-httplib')
-rw-r--r--dev-cpp/cpp-httplib/Manifest1
-rw-r--r--dev-cpp/cpp-httplib/cpp-httplib-0.17.3.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-cpp/cpp-httplib/Manifest b/dev-cpp/cpp-httplib/Manifest
index b4d251b40a3c..7049a82bd9d1 100644
--- a/dev-cpp/cpp-httplib/Manifest
+++ b/dev-cpp/cpp-httplib/Manifest
@@ -3,3 +3,4 @@ DIST cpp-httplib-0.16.0.tar.gz 1156790 BLAKE2B 4a75059f16f6e46685c2cf028c6fa4c9c
DIST cpp-httplib-0.16.2.tar.gz 1157538 BLAKE2B 0fdb3946e33f3af0a6b9646d5edf53572d67fb7e2334923c3ef9784aad569672c21e12c6d0f4c1f91ceccb8d9b3e8f14d51b21f4c6cf252da98024cee47cfcbe SHA512 d0a3d5477cb76cbbbc6da53b0abff3b45fd6b77c0d1686b355ce2904593c67c25849d2b1348e49b0b57ece5be91404fe976b06d75d34eb5068b1e130fd7ddbee
DIST cpp-httplib-0.16.3.tar.gz 1157548 BLAKE2B 986a33043ddf86623f70f50244051089cb6b824866ee247de13772263c691fde2b10e9eeef2078265f0a91b5744dafd2940892cff03c1a9cfd4b35df0d446522 SHA512 1a0d40f17b526db74dfa51903f0d15876b20c836a438be8f87ac2b18e535c3fad1822fbad9cf97053705a2cedc8171ab648e2e8c823eeb2e180c347283f3de9a
DIST cpp-httplib-0.17.2.tar.gz 1259060 BLAKE2B fc1aae7db0edacef59785da18f1ca2b4f5826bbf0ff0624bf8883377cef10b6a6667040afee1f8da989dbe51aa1a6d49bb43b0c94ae5f1c8784f4ff76b455cd5 SHA512 69952c1d881c26004d1bbbb853d4745a65f1b20fbe79c24e8389357b82a59b77a46e76394f4c06a0681a89a10ce21b6de28223e691f06188acfe319811f5d144
+DIST cpp-httplib-0.17.3.tar.gz 1258203 BLAKE2B ea6f51eea2b0bc859b13a4c5bcc9df62ef83c718941d2298f35eba58213fd68546c3347125d00a6e1378a1b31885ea4ed9a62a139411fff097055d135faa176a SHA512 9ee144727470af8a9f6ba953e95227c534ec87c1c89a17d511bb763091336c106e8d3a5fd8d4bf2c2274da0a64d42fde77eb95fb166e59f44bbbe906b3d327ec
diff --git a/dev-cpp/cpp-httplib/cpp-httplib-0.17.3.ebuild b/dev-cpp/cpp-httplib/cpp-httplib-0.17.3.ebuild
new file mode 100644
index 000000000000..d530e23268ec
--- /dev/null
+++ b/dev-cpp/cpp-httplib/cpp-httplib-0.17.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit cmake-multilib python-any-r1 toolchain-funcs
+
+DESCRIPTION="C++ HTTP/HTTPS server and client library"
+HOMEPAGE="https://github.com/yhirose/cpp-httplib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/yhirose/${PN}.git"
+else
+ SRC_URI="https://github.com/yhirose/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)" # soversion
+
+IUSE="brotli ssl test zlib"
+REQUIRED_USE="test? ( brotli ssl zlib )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ brotli? (
+ app-arch/brotli:=[${MULTILIB_USEDEP}]
+ )
+ ssl? (
+ >=dev-libs/openssl-3.0.13:=[${MULTILIB_USEDEP}]
+ )
+ zlib? (
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DHTTPLIB_COMPILE=yes
+ -DBUILD_SHARED_LIBS=yes
+ -DHTTPLIB_USE_BROTLI_IF_AVAILABLE=no
+ -DHTTPLIB_USE_OPENSSL_IF_AVAILABLE=no
+ -DHTTPLIB_USE_ZLIB_IF_AVAILABLE=no
+ -DHTTPLIB_REQUIRE_BROTLI=$(usex brotli)
+ -DHTTPLIB_REQUIRE_OPENSSL=$(usex ssl)
+ -DHTTPLIB_REQUIRE_ZLIB=$(usex zlib)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ cmake-multilib_src_configure
+}
+
+multilib_src_test() {
+ cp -p -R --reflink=auto "${S}/test" ./test || die
+
+ local -a failing_tests=(
+ # Disable all online tests.
+ "*.*_Online"
+
+ # Fails on musl x86:
+ ServerTest.GetRangeWithMaxLongLength
+ ServerTest.GetStreamedWithTooManyRanges
+
+ # https://github.com/yhirose/cpp-httplib/issues/1798
+ # Filed by mgorny's testing, fails on openssl >=3.2:
+ SSLClientServerTest.ClientCertPresent
+ SSLClientServerTest.ClientEncryptedCertPresent
+ SSLClientServerTest.CustomizeServerSSLCtx
+ SSLClientServerTest.MemoryClientCertPresent
+ SSLClientServerTest.MemoryClientEncryptedCertPresent
+ SSLClientServerTest.TrustDirOptional
+ )
+
+ # Little dance to please the GTEST filter (join array using ":").
+ failing_tests_str="${failing_tests[@]}"
+ failing_tests_filter="${failing_tests_str// /:}"
+
+ # PREFIX is . to avoid calling "brew" and relying on stuff in /opt
+ GTEST_FILTER="-${failing_tests_filter}" emake -C test \
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} -I." PREFIX=.
+}