summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-18 21:14:10 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-18 21:15:10 +0200
commita1b6da908b5861efcb29e3a6b534ca8a11117781 (patch)
treedb2e8b7e94798922c8014f6160bf741bf1eb32e5 /dev-build
parentapp-editors/xmlcopyeditor: drop 1.3.1.0 (diff)
downloadgentoo-a1b6da908b5861efcb29e3a6b534ca8a11117781.tar.gz
gentoo-a1b6da908b5861efcb29e3a6b534ca8a11117781.tar.bz2
gentoo-a1b6da908b5861efcb29e3a6b534ca8a11117781.zip
dev-build/cmake: fix compilation on macOS/Darwin
Closes: https://bugs.gentoo.org/933744 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/cmake/cmake-3.30.0.ebuild8
-rw-r--r--dev-build/cmake/cmake-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-build/cmake/cmake-3.30.0.ebuild b/dev-build/cmake/cmake-3.30.0.ebuild
index c119ad22dc76..7957c7bb58b2 100644
--- a/dev-build/cmake/cmake-3.30.0.ebuild
+++ b/dev-build/cmake/cmake-3.30.0.ebuild
@@ -152,6 +152,14 @@ src_prepare() {
sed -i -e '/define CMAKE_USE_XCODE/s/XCODE/NO_XCODE/' \
-e '/cmGlobalXCodeGenerator.h/d' \
Source/cmake.cxx || die
+ # Disable system integration, bug #933744
+ sed -i -e 's/__APPLE__/__DISABLED__/' \
+ Source/cmFindProgramCommand.cxx \
+ Source/CPack/cmCPackGeneratorFactory.cxx || die
+ sed -i -e 's/__MAC_OS_X_VERSION_MIN_REQUIRED/__DISABLED__/' \
+ Source/cmMachO.cxx || die
+ sed -i -e 's:CPack/cmCPack\(Bundle\|DragNDrop\|PKG\|ProductBuild\)Generator.cxx::' \
+ Source/CMakeLists.txt || die
# Disable isysroot usage with GCC, we've properly instructed
# where things are via GCC configuration and ldwrapper
diff --git a/dev-build/cmake/cmake-9999.ebuild b/dev-build/cmake/cmake-9999.ebuild
index 199bff8efd14..f6f904da2105 100644
--- a/dev-build/cmake/cmake-9999.ebuild
+++ b/dev-build/cmake/cmake-9999.ebuild
@@ -153,6 +153,14 @@ src_prepare() {
sed -i -e '/define CMAKE_USE_XCODE/s/XCODE/NO_XCODE/' \
-e '/cmGlobalXCodeGenerator.h/d' \
Source/cmake.cxx || die
+ # Disable system integration, bug #933744
+ sed -i -e 's/__APPLE__/__DISABLED__/' \
+ Source/cmFindProgramCommand.cxx \
+ Source/CPack/cmCPackGeneratorFactory.cxx || die
+ sed -i -e 's/__MAC_OS_X_VERSION_MIN_REQUIRED/__DISABLED__/' \
+ Source/cmMachO.cxx || die
+ sed -i -e 's:CPack/cmCPack\(Bundle\|DragNDrop\|PKG\|ProductBuild\)Generator.cxx::' \
+ Source/CMakeLists.txt || die
# Disable isysroot usage with GCC, we've properly instructed
# where things are via GCC configuration and ldwrapper