summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-11 00:16:06 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-11 12:28:29 -0400
commit286a9a66fb3d1f9643f4751c8f65affa6fff7e89 (patch)
treec8c30d3b34357862e7b005d11b5fc7d097189dfc /dev-build
parentdev-lang/gdl: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-286a9a66fb3d1f9643f4751c8f65affa6fff7e89.tar.gz
gentoo-286a9a66fb3d1f9643f4751c8f65affa6fff7e89.tar.bz2
gentoo-286a9a66fb3d1f9643f4751c8f65affa6fff7e89.zip
dev-build/meson: skip another test that inexplicably fails
I do not know why clippy-driver fails to compile sanity.rs, but it does. It works flawlessly outside of portage, and is tested like that in upstream CI running on Gentoo. And tests pass on my machine, in a git checkout of meson. But not when running the same thing in portage. Even manually constructing a sanity.rs file in ${FILESDIR} and executing `clippy-driver ...` in src_test fails, but the exact same command run inside of `sudo -u portage bash` upon the same file, succeeds. It's not the portage sandbox, but it is something about the portage environment, and I have not been able to figure out what. And it's making it impossible to run the testsuite. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/meson/meson-1.4.2.ebuild6
-rw-r--r--dev-build/meson/meson-1.5.0.ebuild6
-rw-r--r--dev-build/meson/meson-9999.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/dev-build/meson/meson-1.4.2.ebuild b/dev-build/meson/meson-1.4.2.ebuild
index 1d559a807e62..4b7ba1a3634a 100644
--- a/dev-build/meson/meson-1.4.2.ebuild
+++ b/dev-build/meson/meson-1.4.2.ebuild
@@ -82,6 +82,12 @@ python_prepare_all() {
# ASAN is unsupported on some targets
# https://bugs.gentoo.org/692822
-e 's/test_pch_with_address_sanitizer/_&/'
+
+ # clippy-driver fails, but only when run via portage.
+ #
+ # error[E0463]: can't find crate for `std`
+ # error: requires `sized` lang_item
+ -e 's/test_rust_clippy/_&/'
)
sed -i "${disable_unittests[@]}" unittests/*.py || die
diff --git a/dev-build/meson/meson-1.5.0.ebuild b/dev-build/meson/meson-1.5.0.ebuild
index 2a1d8a788dbb..762876dc5e40 100644
--- a/dev-build/meson/meson-1.5.0.ebuild
+++ b/dev-build/meson/meson-1.5.0.ebuild
@@ -82,6 +82,12 @@ python_prepare_all() {
# ASAN is unsupported on some targets
# https://bugs.gentoo.org/692822
-e 's/test_pch_with_address_sanitizer/_&/'
+
+ # clippy-driver fails, but only when run via portage.
+ #
+ # error[E0463]: can't find crate for `std`
+ # error: requires `sized` lang_item
+ -e 's/test_rust_clippy/_&/'
)
sed -i "${disable_unittests[@]}" unittests/*.py || die
diff --git a/dev-build/meson/meson-9999.ebuild b/dev-build/meson/meson-9999.ebuild
index 2a1d8a788dbb..762876dc5e40 100644
--- a/dev-build/meson/meson-9999.ebuild
+++ b/dev-build/meson/meson-9999.ebuild
@@ -82,6 +82,12 @@ python_prepare_all() {
# ASAN is unsupported on some targets
# https://bugs.gentoo.org/692822
-e 's/test_pch_with_address_sanitizer/_&/'
+
+ # clippy-driver fails, but only when run via portage.
+ #
+ # error[E0463]: can't find crate for `std`
+ # error: requires `sized` lang_item
+ -e 's/test_rust_clippy/_&/'
)
sed -i "${disable_unittests[@]}" unittests/*.py || die