summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2025-01-06 11:52:16 +0100
committerAlfredo Tupone <tupone@gentoo.org>2025-01-06 11:54:46 +0100
commit1fe412abf6da7ea782726fc999dc1cd6487d9a4b (patch)
treecec9bd47b6e8f9e8bd52aae8fbe740375ffd26ca /dev-ada
parentdev-libs/libfmt: Keyword 11.1.1 mips, #947604 (diff)
downloadgentoo-1fe412abf6da7ea782726fc999dc1cd6487d9a4b.tar.gz
gentoo-1fe412abf6da7ea782726fc999dc1cd6487d9a4b.tar.bz2
gentoo-1fe412abf6da7ea782726fc999dc1cd6487d9a4b.zip
dev-ada/e3-core: add 22.6.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/e3-core/Manifest1
-rw-r--r--dev-ada/e3-core/e3-core-22.6.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ada/e3-core/Manifest b/dev-ada/e3-core/Manifest
index 8421bc65db25..9e1ac50840ad 100644
--- a/dev-ada/e3-core/Manifest
+++ b/dev-ada/e3-core/Manifest
@@ -1 +1,2 @@
DIST e3-core-22.4.0.tar.gz 484431 BLAKE2B fb0d12ea30544a33b1bd3c9e3c7571defb5226faa94fc54e5f25b8b9613a586d9e9a84f973903e150f2dff81b4806afb95df31611ced4452f2d3f892db4f6e3b SHA512 afa99afb16ec8498be62b1ed49ebd2ba057b75fa1d5b37ab5cebd40bc0f70704883211bb37be34a3be98079b7e056963f9d35c338fb20525fa009b968dd83909
+DIST e3-core-22.6.0.tar.gz 558104 BLAKE2B 95cc2a6d1c8570a3a0efa91676b4b1c2eac17b58e570084218e264ce36eb9662b0d7ef713afe01d4081db84d7416af608434be23179af6b7953b13400a9225ad SHA512 66707dc2d6d38f32e511587053b9c2f2457e0516ee4c98e06077abe596b77bb7c20a3a43c966f22e7f0339c6d15905649e237035e1abb012b4d5eb533f852f88
diff --git a/dev-ada/e3-core/e3-core-22.6.0.ebuild b/dev-ada/e3-core/e3-core-22.6.0.ebuild
new file mode 100644
index 000000000000..8028993db17b
--- /dev/null
+++ b/dev-ada/e3-core/e3-core-22.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Ease the development of portable automated build systems"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" #require pytest-socket
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ !app-editors/e3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-vcs/subversion
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.1.0-test.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_compile() {
+ local PLATFORM=x86_64-linux
+ rm src/e3/os/data/rlimit* || die
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
+ distutils-r1_src_compile
+}