summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-05-21 21:49:56 +0200
committerUlrich Müller <ulm@gentoo.org>2022-05-21 22:03:15 +0200
commitd7c2243c11ecc16f19d098d2f1144ab3e901e3ae (patch)
tree69b1e5f8d1c426575eb356e21b95a9ad0c835358 /app-xemacs
parentapp-emacs/ebuild-mode: Remove intermediate version (diff)
downloadgentoo-d7c2243c11ecc16f19d098d2f1144ab3e901e3ae.tar.gz
gentoo-d7c2243c11ecc16f19d098d2f1144ab3e901e3ae.tar.bz2
gentoo-d7c2243c11ecc16f19d098d2f1144ab3e901e3ae.zip
app-xemacs/ebuild-mode: Version bump to 1.60
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.60.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index 6ffeacf1dece..76efb12043fa 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1,3 +1,4 @@
DIST ebuild-mode-1.56.tar.xz 36448 BLAKE2B 9126dd5d004a5818a5214f10c88db84faee3945ac25ee141a577a868bf7f127490ee34d6ea103fb788f96c391eea3d00d18abe12564a2f6c70650fc8fe9c6cdf SHA512 2b67208d9f553a322761dc9b64e7b891722c2099cc7c9bfc929e1a424b22ec32c594e0ba029554434b51ef233d2d4435b6c639b06c25fd551608fe5dd830cb03
DIST ebuild-mode-1.58.tar.xz 36796 BLAKE2B c2762c0d00038206d9ceacb887c2c0a1503e7e5dbdc68796aaa27eec5cab52fae1d6e4baf5155b79842fd2e74d91dab1c203c26d9f68986155426b36635b7722 SHA512 37e393b5c5b6672045dea7aafa77df81f7aee2d16ead90e12841026442eac63fe3eece1538401dc4b7444573aec61f4c920f821b65f8489b5a48d54de4d78b52
DIST ebuild-mode-1.59.tar.xz 36936 BLAKE2B f0b4a6edbf89e9702110bfd79d0db3b0b1f78d22e0d6803f5b60bd668d9824692541462ba9a9acc5f6f0c26d2799fd9eda6bb98f20482061b64e344fe44b2625 SHA512 3f08baf18f93a0685ce2a72c91732e088a74db031d9d227025718dafeb67d3760a8fd2b91cc266741aa6ed384e8b10f4e9057f11db4507c908398ff3c5a76744
+DIST ebuild-mode-1.60.tar.xz 36996 BLAKE2B a566c9f602ec6ac4126a4a13610e515faf2a02b8ca89f417a037a28f4b9ea633518d589d78f6deb54084be34cdc30c2a1896546b2f86c1166cedd47289edcfd8 SHA512 b04b37b7a376dc48a7f80ec0e60bf36a8b7ea92edcbdd45fbd002e80e8ea29111905a726177a869d607adffe78094efcdc94b1aad32afe1444a09b4e714dcecd
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.60.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.60.ebuild
new file mode 100644
index 000000000000..44559c96c2ab
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ local XEMACS="${EPREFIX}/usr/bin/xemacs"
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_install() {
+ insinto /usr/share/xemacs/site-packages/lisp/${PN}
+ doins *.el *.elc
+}