summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-06-02 10:53:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-06-02 10:53:57 -0700
commitba43beb1575eff7d68d2bdeb937d8e0fab5f4b16 (patch)
tree1e7581dc799b2f338a07e0d02dc8c011ef6bbc66 /app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild
parentnet-wireless/gr-iio: fix QA issue (diff)
downloadgentoo-ba43beb1575eff7d68d2bdeb937d8e0fab5f4b16.tar.gz
gentoo-ba43beb1575eff7d68d2bdeb937d8e0fab5f4b16.tar.bz2
gentoo-ba43beb1575eff7d68d2bdeb937d8e0fab5f4b16.zip
app-vim/editorconfig-vim-1.1.1: Version bump
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild')
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild
new file mode 100644
index 000000000000..300d91dcfbdc
--- /dev/null
+++ b/app-vim/editorconfig-vim/editorconfig-vim-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="vim plugin: Support EditorConfig files "
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2 PSF-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"
+
+src_prepare() {
+ default
+
+ rm LICENSE LICENSE.PSF \
+ mkzip.sh .editorconfig \
+ .git{ignore,modules} \
+ .{travis,appveyor}.yml || die
+}
+
+src_install() {
+ # we don't want to install the tests
+ rm -r tests || die
+
+ vim-plugin_src_install
+}