summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2025-01-17 11:10:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2025-01-17 11:10:55 +0200
commit4b0abb079cfacd7bed2de3413cea91a95859f3f6 (patch)
tree4aacb2c0734db547f114dd136ba103366746ad75 /app-text/sigil
parentdev-ruby/rubygems: drop 3.5.3, 3.5.9 (diff)
downloadgentoo-4b0abb079cfacd7bed2de3413cea91a95859f3f6.tar.gz
gentoo-4b0abb079cfacd7bed2de3413cea91a95859f3f6.tar.bz2
gentoo-4b0abb079cfacd7bed2de3413cea91a95859f3f6.zip
app-text/sigil: add 2.4.0
Closes: https://bugs.gentoo.org/946362 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/sigil-2.4.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index 06132754c925..1b0c869912e1 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1,2 +1,3 @@
DIST Sigil_User_Guide_2024.08.15.epub 12641984 BLAKE2B feaa8a4f6b64786d5cbf494a61c8726a5dd3e169ca8902348e2fee9f890ab7496b5ad018d49d6cecd65cb3d3d4a9b4a6bda019ac52c324fa92fad3e7b5dbc680 SHA512 10199c037a57f4b9ed913a8c726a58e376dcd34300a98cdd4cf934fd3a2f9a26d2f92bd85131af7ee1084824d7b082f7becdec9b0731a62f9cde712bfada5a09
DIST sigil-2.3.1.tar.gz 17475697 BLAKE2B 668d02f941c900921224977bc2d8edeb6a21cf7985d1f7980ffc6b8ecc6627fe5a29f71ea75e12d1f54c2b1959afa7323dda807b1189e4189a996e98c90bdea2 SHA512 da0433882040212a8385c1b872b568ef39660b6c0127d64d9fc4cdd4f3939c2e14f3d08056ab1b405142e012caf363ebfe170761a74e684590c1a358e1115d09
+DIST sigil-2.4.0.tar.gz 19135045 BLAKE2B 311fe0894818c08fc5ecee8b29b04e24aa8f13d4f28b1011f455fcf7944561e68832ddd36885f69f794333bb790b7b84c49bc6d3d2367772150e936708916d0c SHA512 1c5687f31494ea5f1c8e3ac5fe3c3892ee68a0645795c57f10802d4e579c95a4ef5e3cb0fedc598f647282b3fe7b56e1a3efd547e08a44fea4619ae5b9581c20
diff --git a/app-text/sigil/sigil-2.4.0.ebuild b/app-text/sigil/sigil-2.4.0.ebuild
new file mode 100644
index 000000000000..c071247e701b
--- /dev/null
+++ b/app-text/sigil/sigil-2.4.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit xdg cmake python-single-r1
+
+DOC_VERSION="2024.08.15"
+DOC_FILE="Sigil_User_Guide_${DOC_VERSION}.epub"
+
+DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
+SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/Sigil-Ebook/sigil-user-guide/releases/download/${DOC_VERSION}/${DOC_FILE} )"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-3+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +plugins +system-mathjax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/hunspell:=
+ dev-libs/libpcre2:=[pcre16]
+ dev-qt/qtbase:6[concurrent,cups,network,widgets,xml]
+ dev-qt/qtwebengine:6[widgets]
+ dev-qt/qtsvg:6
+ sys-libs/zlib[minizip]
+ $(python_gen_cond_dep '
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+ plugins? (
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6-webengine[${PYTHON_USEDEP}]
+ ')
+ $(python_gen_impl_dep 'tk')
+ )
+ system-mathjax? ( >=dev-libs/mathjax-3 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-qt/qttools:6[linguist]
+"
+
+DOCS=( ChangeLog.txt README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTRY_NEWER_FINDPYTHON3=1
+ -DPython3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPython3_LIBRARY="$(python_get_library_path)"
+ -DPython3_EXECUTABLE="${PYTHON}"
+
+ -DUSE_VIRT_PY=0
+ -DINSTALL_BUNDLED_DICTS=0
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DUSE_SYSTEM_LIBS=1
+ )
+ use system-mathjax && mycmakeargs+=( -DMATHJAX3_DIR="${EPREFIX}"/usr/share/mathjax )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"/usr/share/sigil/
+ python_optimize "${ED}"/usr/share/sigil/
+
+ if use doc; then
+ dodoc "${DISTDIR}/${DOC_FILE}"
+ docompress -x /usr/share/doc/${PF}/${DOC_FILE}
+ fi
+}