summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/XML-Schema-learner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/XML-Schema-learner')
-rw-r--r--app-text/XML-Schema-learner/Manifest2
-rw-r--r--app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild38
-rw-r--r--app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild38
-rw-r--r--app-text/XML-Schema-learner/metadata.xml24
4 files changed, 102 insertions, 0 deletions
diff --git a/app-text/XML-Schema-learner/Manifest b/app-text/XML-Schema-learner/Manifest
new file mode 100644
index 000000000000..d0af23ed3992
--- /dev/null
+++ b/app-text/XML-Schema-learner/Manifest
@@ -0,0 +1,2 @@
+DIST XML-Schema-learner-1.0.0.tar.gz 50690 SHA256 b68fe6c090c3e175e52e0e9f037412eb11725951a54c6a884246fcd2c9465a83 SHA512 aa1b696fbec13d3a345f063e055f77f17832ceb11294a73ac393363684d754f0274ffc59bfc048315bbe2cba8a012cd012ee9ce4f7de12b5695bad60485564bd WHIRLPOOL ddd0afd6056bfa8c617d0a310512d2d4353282f44b8bac140ff299533e689693aa268c189c3c617ecd3e638a00d6994e92e1b6cfa1f8a5c692605f9f12635930
+DIST XML-Schema-learner-1.0.1.tar.gz 51057 SHA256 79e9416db683fee9463ba895283423661e05aa8de2b15c9ea2372c83110ab011 SHA512 f357c1a99ac6a7f807538910dfe5e19b14f789046816d333cb031addfbffc0858fd5641f52dcd7304417d0cf0b6c45d1eb3f2092652c4891c09fc45dd26feb9d WHIRLPOOL 810a51fa5920d46f96e82d018c95e9524dfc85b433fd1579f90a7ff241e6300dc88f166725e68f58a0aac1658fc92ba374da03e3995ed22ba08da23e6003df43
diff --git a/app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild
new file mode 100644
index 000000000000..bc7c09624c91
--- /dev/null
+++ b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
+HOMEPAGE="https://github.com/kore/${PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+# PHP dependency can be inferred from .travis.yml in the repository.
+# The necessary USE flags on the other hand were found the hard way.
+#
+# The dependencies here aren't as expressive as they should be. What we
+# really want is for php[...] to apply to everything in PHP_TARGETS, and
+# for those interpreters (the ones in PHP_TARGETS) to be used to run the
+# test suite.
+#
+# See bug #497606.
+#
+RDEPEND="dev-lang/php:*[cli,xml,xmlreader]"
+DEPEND="test? ( ${RDEPEND}
+ dev-php/phpunit )"
+
+src_compile() {
+ # Don't run make, the default target is 'check'.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README.rst
+}
diff --git a/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild
new file mode 100644
index 000000000000..b0d391dd48b6
--- /dev/null
+++ b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
+HOMEPAGE="https://github.com/kore/${PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+# PHP dependency can be inferred from .travis.yml in the repository.
+# The necessary USE flags on the other hand were found the hard way.
+#
+# The dependencies here aren't as expressive as they should be. What we
+# really want is for php[...] to apply to everything in PHP_TARGETS, and
+# for those interpreters (the ones in PHP_TARGETS) to be used to run the
+# test suite.
+#
+# See bug #497606.
+#
+RDEPEND="dev-lang/php:*[cli,xml,xmlreader]"
+DEPEND="test? ( ${RDEPEND}
+ dev-php/phpunit )"
+
+src_compile() {
+ # Don't run make, the default target is 'check'.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README.rst
+}
diff --git a/app-text/XML-Schema-learner/metadata.xml b/app-text/XML-Schema-learner/metadata.xml
new file mode 100644
index 000000000000..1988ca282eeb
--- /dev/null
+++ b/app-text/XML-Schema-learner/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This software implements various state-of-the-art algorithms for
+ algorithmic learning of XML Schema definitions and Document Type
+ Definitions.
+
+ Given a set or a single XML instance it can algorithmically infer
+ a schema which describes the XML instances. The resulting schemas
+ are of high-quality and human readable.
+
+ The theory behind the project is described in Kore Nordmann's
+ thesis, "Algorithmic learning of XML Schema definitions from XML
+ data," available at
+ http://kore-nordmann.de/talks/11_03_learning_xml_schema_definitions_from_xml_data.pdf.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kore/XML-Schema-learner</remote-id>
+ </upstream>
+</pkgmetadata>