summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-06-28 10:02:30 -0500
committerBen Kohler <bkohler@gentoo.org>2023-06-29 14:57:26 -0500
commitc9f4376eb1b1ac1134fa71e74c52b53c594635c2 (patch)
treef93dcc478cdd9efa38f506e2896ebcb8db45602d /app-portage
parentnet-libs/nodejs: add 20.3.1 (diff)
downloadgentoo-c9f4376eb1b1ac1134fa71e74c52b53c594635c2.tar.gz
gentoo-c9f4376eb1b1ac1134fa71e74c52b53c594635c2.tar.bz2
gentoo-c9f4376eb1b1ac1134fa71e74c52b53c594635c2.zip
app-portage/portage-utils: make best effort to get gcc[openmp] installed
Bug: https://bugs.gentoo.org/890752 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/portage-utils-0.95-r1.ebuild75
-rw-r--r--app-portage/portage-utils/portage-utils-0.96-r1.ebuild75
-rw-r--r--app-portage/portage-utils/portage-utils-9999.ebuild8
3 files changed, 154 insertions, 4 deletions
diff --git a/app-portage/portage-utils/portage-utils-0.95-r1.ebuild b/app-portage/portage-utils/portage-utils-0.95-r1.ebuild
new file mode 100644
index 000000000000..e9bf09edc335
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.95-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="openmp +qmanifest +qtegrity static"
+
+RDEPEND="
+ openmp? ( || (
+ sys-devel/gcc:*[openmp]
+ sys-libs/libomp
+ ) )
+ qmanifest? (
+ !static? (
+ app-crypt/gpgme:=
+ app-crypt/libb2:=
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ )
+ )
+ qtegrity? (
+ !static? (
+ dev-libs/openssl:=
+ )
+ )"
+DEPEND="${RDEPEND}
+ qmanifest? (
+ static? (
+ app-crypt/gpgme[static-libs]
+ app-crypt/libb2[static-libs]
+ dev-libs/openssl[static-libs]
+ sys-libs/zlib[static-libs]
+ )
+ )
+ qtegrity? (
+ static? (
+ dev-libs/openssl[static-libs]
+ )
+ )"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable qtegrity) \
+ $(use_enable openmp)
+}
diff --git a/app-portage/portage-utils/portage-utils-0.96-r1.ebuild b/app-portage/portage-utils/portage-utils-0.96-r1.ebuild
new file mode 100644
index 000000000000..e9bf09edc335
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.96-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="openmp +qmanifest +qtegrity static"
+
+RDEPEND="
+ openmp? ( || (
+ sys-devel/gcc:*[openmp]
+ sys-libs/libomp
+ ) )
+ qmanifest? (
+ !static? (
+ app-crypt/gpgme:=
+ app-crypt/libb2:=
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ )
+ )
+ qtegrity? (
+ !static? (
+ dev-libs/openssl:=
+ )
+ )"
+DEPEND="${RDEPEND}
+ qmanifest? (
+ static? (
+ app-crypt/gpgme[static-libs]
+ app-crypt/libb2[static-libs]
+ dev-libs/openssl[static-libs]
+ sys-libs/zlib[static-libs]
+ )
+ )
+ qtegrity? (
+ static? (
+ dev-libs/openssl[static-libs]
+ )
+ )"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable qtegrity) \
+ $(use_enable openmp)
+}
diff --git a/app-portage/portage-utils/portage-utils-9999.ebuild b/app-portage/portage-utils/portage-utils-9999.ebuild
index 2df55d2cb16d..a40fd823f800 100644
--- a/app-portage/portage-utils/portage-utils-9999.ebuild
+++ b/app-portage/portage-utils/portage-utils-9999.ebuild
@@ -21,6 +21,10 @@ SLOT="0"
IUSE="openmp +qmanifest +qtegrity static"
RDEPEND="
+ openmp? ( || (
+ sys-devel/gcc:*[openmp]
+ sys-libs/libomp
+ ) )
qmanifest? (
!static? (
app-crypt/gpgme:=
@@ -50,10 +54,6 @@ DEPEND="${RDEPEND}
)"
BDEPEND="virtual/pkgconfig"
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}