summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-08-03 09:29:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-08-03 09:29:07 +0200
commit4976e8b958b3b05d3820f2b1b2e7a0e9fcdcc105 (patch)
treed83343d47c63f6ba8b6a12836031be44fa403c7f /app-portage
parentwww-client/firefox-bin: drop 128.0, 128.0.2 (diff)
downloadgentoo-4976e8b958b3b05d3820f2b1b2e7a0e9fcdcc105.tar.gz
gentoo-4976e8b958b3b05d3820f2b1b2e7a0e9fcdcc105.tar.bz2
gentoo-4976e8b958b3b05d3820f2b1b2e7a0e9fcdcc105.zip
app-portage/command-not-found: add 0.0.6
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/command-not-found/Manifest1
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
index abd98307c6b6..5dee0b041929 100644
--- a/app-portage/command-not-found/Manifest
+++ b/app-portage/command-not-found/Manifest
@@ -1 +1,2 @@
DIST command-not-found-0.0.5.tar.gz 10045 BLAKE2B 5225fe4512516518172b1c7d25563488f26b359e0698a3352ebf2143dd7983fee2c44050e2b4abf72377780875436861855f0891bc10d429fba9bba695808bf3 SHA512 9125e168d64b7474f83d1bc8ed7f54ef332190d0d7325c281f1a041d47b23ce18170dff2fa3342468941cba7b0197821790ef5d1e9b8c1ee1f5a6ba1383b1005
+DIST command-not-found-0.0.6.tar.gz 10290 BLAKE2B 352a77790539acca9d54902e8078b580a5f4a789d61c395944363b4a42f8750cd518e3d8a22f69c409c8ab090cf6345677c324f3faa1e67071439cd6f600c7a3 SHA512 9396b7cb1cbcbc53047928ede0f77613e7f5ad3d5855f6476c40642c52a419aa6227e9b329d8d73d267fbd946e36f21740420ea854555025ddd2ea7eb1dbcec2
diff --git a/app-portage/command-not-found/command-not-found-0.0.6.ebuild b/app-portage/command-not-found/command-not-found-0.0.6.ebuild
new file mode 100644
index 000000000000..4943e69c1ba9
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} is automatically setup for app-shells/bash, see"
+ elog " /usr/share/doc/${PF}/README.md"
+ elog "for instructions on how to set it up for various other shells."
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}