summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-22 17:45:19 +0100
committerSam James <sam@gentoo.org>2023-04-22 17:47:30 +0100
commit46f5f2f97a7786d593d77593844096d5ce84c501 (patch)
tree11d5cea963fc4b3432999b1538f6d241a64ed977 /app-office
parentdev-ruby/stringio: Stabilize 3.0.5 x86, #904205 (diff)
downloadgentoo-46f5f2f97a7786d593d77593844096d5ce84c501.tar.gz
gentoo-46f5f2f97a7786d593d77593844096d5ce84c501.tar.bz2
gentoo-46f5f2f97a7786d593d77593844096d5ce84c501.zip
app-office/calligra: fix configure w/ clang 16
May be misconfigured otherwise. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/calligra-3.2.1-r8.ebuild (renamed from app-office/calligra/calligra-3.2.1-r7.ebuild)1
-rw-r--r--app-office/calligra/files/calligra-3.2.1-clang-16-configure.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/app-office/calligra/calligra-3.2.1-r7.ebuild b/app-office/calligra/calligra-3.2.1-r8.ebuild
index 27b0ebbf1634..d757ece3bddd 100644
--- a/app-office/calligra/calligra-3.2.1-r7.ebuild
+++ b/app-office/calligra/calligra-3.2.1-r8.ebuild
@@ -126,6 +126,7 @@ PATCHES=(
"${WORKDIR}"/${PATCHSET}/${P}-clang-16-c++17.patch
"${WORKDIR}"/${PATCHSET}/${P}-kross-optional.patch # bug 903532
"${FILESDIR}"/${P}-use-cmake-FindGSL-module.patch # bug 903343
+ "${FILESDIR}"/${P}-clang-16-configure.patch
)
pkg_pretend() {
diff --git a/app-office/calligra/files/calligra-3.2.1-clang-16-configure.patch b/app-office/calligra/files/calligra-3.2.1-clang-16-configure.patch
new file mode 100644
index 000000000000..c723eca0b75f
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.2.1-clang-16-configure.patch
@@ -0,0 +1,19 @@
+https://invent.kde.org/office/calligra/-/merge_requests/81
+https://invent.kde.org/office/calligra/-/commit/30c905a6a34ad656446839c844abb78a2aa3f586
+
+From 30c905a6a34ad656446839c844abb78a2aa3f586 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Wed, 19 Apr 2023 10:34:25 +0200
+Subject: [PATCH] Avoid implicit declaration of atoi in CMake check
+
+Future compilers will not support implicit function declarations by
+default, so include <stdlib.h> for a declaration of atoi.
+--- a/cmake/TestModernZlib.c
++++ b/cmake/TestModernZlib.c
+@@ -1,3 +1,4 @@
++#include <stdlib.h>
+ #include <string.h>
+ #include <zlib.h>
+
+--
+GitLab