summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-04-13 09:45:44 +0200
committerUlrich Müller <ulm@gentoo.org>2023-04-13 09:50:50 +0200
commit02089febeadb875ef39ba0cc66609f9c8679e258 (patch)
tree96d79d788a035aa17a4f19ee34528de2dfe883a4 /app-misc/pdfpc
parentsys-libs/ncurses: add 6.4_p20230401 (diff)
downloadgentoo-02089febeadb875ef39ba0cc66609f9c8679e258.tar.gz
gentoo-02089febeadb875ef39ba0cc66609f9c8679e258.tar.bz2
gentoo-02089febeadb875ef39ba0cc66609f9c8679e258.zip
app-misc/pdfpc: Fix compile failure with USE=-gstreamer
Closes: https://bugs.gentoo.org/904241 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-misc/pdfpc')
-rw-r--r--app-misc/pdfpc/files/pdfpc-4.6.0-no-movies.patch59
-rw-r--r--app-misc/pdfpc/pdfpc-4.6.0-r1.ebuild2
2 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/pdfpc/files/pdfpc-4.6.0-no-movies.patch b/app-misc/pdfpc/files/pdfpc-4.6.0-no-movies.patch
new file mode 100644
index 000000000000..9767dc2a8093
--- /dev/null
+++ b/app-misc/pdfpc/files/pdfpc-4.6.0-no-movies.patch
@@ -0,0 +1,59 @@
+https://github.com/pdfpc/pdfpc/issues/672
+https://bugs.gentoo.org/904241
+
+commit a6501085b3e94eb4a01db18fe9dc15d51fcde3a3
+Author: Evgeny Stambulchik <fnevgeny@gmail.com>
+Date: Sat, 11 Feb 2023 23:04:19 +0200
+
+ Skip MOVIE actions when configured with -DMOVIES
+
+--- a/src/classes/action/link_action.vala
++++ b/src/classes/action/link_action.vala
+@@ -47,6 +47,7 @@
+ this.action = mapping.action.copy();
+ }
+
++#if MOVIES
+ /**
+ * Find movie on the current slide by its filename; there seems to be
+ * no better way with the current Glib Poppler bindings.
+@@ -71,6 +72,7 @@
+
+ return null;
+ }
++#endif
+
+ /**
+ * Create from the LinkMapping if the link is an internal link to a named
+@@ -91,6 +93,7 @@
+ return new_obj as ActionMapping;
+ }
+ break;
++#if MOVIES
+ case Poppler.ActionType.MOVIE:
+ unowned var movie_action = (Poppler.ActionMovie*) mapping.action;
+ var movie = movie_action.movie;
+@@ -100,6 +103,7 @@
+ return new_obj as ActionMapping;
+ }
+ break;
++#endif
+ default:
+ break;
+ }
+@@ -167,6 +171,7 @@
+ this.controller.switch_to_slide_number(slide_number);
+
+ break;
++#if MOVIES
+ case Poppler.ActionType.MOVIE:
+ unowned var action = (Poppler.ActionMovie*) this.action;
+ var movie = action.movie;
+@@ -192,6 +197,7 @@
+ }
+ }
+ break;
++#endif
+ default:
+ return false;
+ }
diff --git a/app-misc/pdfpc/pdfpc-4.6.0-r1.ebuild b/app-misc/pdfpc/pdfpc-4.6.0-r1.ebuild
index 884855a57e36..c5e511d5a6f4 100644
--- a/app-misc/pdfpc/pdfpc-4.6.0-r1.ebuild
+++ b/app-misc/pdfpc/pdfpc-4.6.0-r1.ebuild
@@ -55,6 +55,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="$(vala_depend)"
+PATCHES=("${FILESDIR}/${P}-no-movies.patch")
+
DOCS=(
CHANGELOG.rst
FAQ.rst