summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-20 04:49:45 +0100
committerSam James <sam@gentoo.org>2022-10-20 04:50:11 +0100
commit9c83c91ab52747439175091db2509e34c2a89122 (patch)
treefd9805af22098f19b8a31d68f4d869b96ec5c2ec /app-misc/cw
parentapp-misc/cw: 1.0.16 revbump, fix build for clang16 (diff)
downloadgentoo-9c83c91ab52747439175091db2509e34c2a89122.tar.gz
gentoo-9c83c91ab52747439175091db2509e34c2a89122.tar.bz2
gentoo-9c83c91ab52747439175091db2509e34c2a89122.zip
app-misc/cw: respect CPPFLAGS
Bug: https://bugs.gentoo.org/870751 Fixes: af397b3d6dec93a39eb752d80dd10695d654958a Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/cw')
-rw-r--r--app-misc/cw/cw-1.0.16-r5.ebuild8
-rw-r--r--app-misc/cw/files/cw-1.0.16-Respect-CPPFLAGS.patch21
2 files changed, 24 insertions, 5 deletions
diff --git a/app-misc/cw/cw-1.0.16-r5.ebuild b/app-misc/cw/cw-1.0.16-r5.ebuild
index c66048665427..055fddd637fe 100644
--- a/app-misc/cw/cw-1.0.16-r5.ebuild
+++ b/app-misc/cw/cw-1.0.16-r5.ebuild
@@ -21,23 +21,21 @@ PATCHES=(
"${FILESDIR}"/${PV}-format-security.patch
"${FILESDIR}"/${P}-replace-isastream-with-fcntl.patch
"${FILESDIR}"/${P}-fix-configure-for-newer-autotools.patch
+ "${FILESDIR}"/${P}-Respect-CPPFLAGS.patch
)
-src_unpack() {
+src_prepare() {
default
gunzip "${S}"/man/*.gz || die
-}
-src_prepare() {
- default
eautoreconf
}
src_configure() {
tc-export CC
- append-flags -D_XOPEN_SOURCE=500 -D_GNU_SOURCE
+ append-cppflags -D_GNU_SOURCE
econf
}
diff --git a/app-misc/cw/files/cw-1.0.16-Respect-CPPFLAGS.patch b/app-misc/cw/files/cw-1.0.16-Respect-CPPFLAGS.patch
new file mode 100644
index 000000000000..b1ae96daf4a4
--- /dev/null
+++ b/app-misc/cw/files/cw-1.0.16-Respect-CPPFLAGS.patch
@@ -0,0 +1,21 @@
+From 64249a5b7e2aaa4b53e41deb767a164cf5b68421 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 20 Oct 2022 04:48:48 +0100
+Subject: [PATCH] Respect CPPFLAGS
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -19,11 +19,11 @@ all:
+
+ cw:
+ @$(ECHO) "* Compiling cw(color wrapper)..."
+- $(CC) $(CFLAGS) $(LDFLAGS) src/cw.c -o bin/cw @CFLAGS@ @LIBS@ @DEFS@
++ $(CC) $(CPPFLAGS) @DEFS@ $(CFLAGS) @CFLAGS@ $(LDFLAGS) src/cw.c -o bin/cw @LIBS@
+
+ cwu:
+ @$(ECHO) "* Compiling cwu(color wrapper directive updater)..."
+- $(CC) $(CFLAGS) $(LDFLAGS) src/cwu.c -o bin/cwu
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) src/cwu.c -o bin/cwu
+
+ local: cw cwu
+