summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-12 14:42:06 +0200
committerChristoph Junghans <ottxor@gentoo.org>2015-09-13 12:12:13 -0600
commit66556e011379356d5760f615bfcf767e35be3a9c (patch)
tree5b45cd07b839d14c11263474b09f7c2dde5ff596 /app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild
parentx11-wm/page: Version bump. (diff)
downloadgentoo-66556e011379356d5760f615bfcf767e35be3a9c.tar.gz
gentoo-66556e011379356d5760f615bfcf767e35be3a9c.tar.bz2
gentoo-66556e011379356d5760f615bfcf767e35be3a9c.zip
app-laptop/tpacpi-bat: Version bump (close #86 gh)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild')
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild
new file mode 100644
index 000000000000..06144e803801
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git https://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
+ systemd_newunit tpacpi.service ${PN}.service
+}