summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2023-06-26 22:22:06 -0700
committerGöktürk Yüksek <gokturk@gentoo.org>2023-06-26 22:24:55 -0700
commit02148b29dc4cce3de2ed4781e07c561963668f2d (patch)
treedb11e432d0359e248c9e6216d89fc280fadb1393 /app-forensics
parentdev-ruby/rails: add 7.0.5.1 (diff)
downloadgentoo-02148b29dc4cce3de2ed4781e07c561963668f2d.tar.gz
gentoo-02148b29dc4cce3de2ed4781e07c561963668f2d.tar.bz2
gentoo-02148b29dc4cce3de2ed4781e07c561963668f2d.zip
app-forensics/sleuthkit: fix configure.ac to use '==' instead of '='
Address a build time issue where using '==' may fail with: test: xyes: unexpected operator silently disabling the build of Java support, ultimately leading to failure in src_install. Bug: https://bugs.gentoo.org/870250 Url: https://github.com/sleuthkit/sleuthkit/pull/2835 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-4.12.0-configure-ac-test-fix.patch34
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.12.0.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/app-forensics/sleuthkit/files/sleuthkit-4.12.0-configure-ac-test-fix.patch b/app-forensics/sleuthkit/files/sleuthkit-4.12.0-configure-ac-test-fix.patch
new file mode 100644
index 000000000000..2bb52435fd9a
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-4.12.0-configure-ac-test-fix.patch
@@ -0,0 +1,34 @@
+https://github.com/sleuthkit/sleuthkit/pull/2835
+
+From fd19051920849343631df1cbf8d4b86f1bf98b2c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
+Date: Mon, 26 Jun 2023 22:05:47 -0700
+Subject: [PATCH] configure.ac: use '=' for comparison instead of '=='
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The operator '==' isn't POSIX compliant[0]. Use the standard '=', as it's
+done everywhere else in configure.ac.
+
+[0] https://pubs.opengroup.org/onlinepubs/9699919799/utilities/test.html
+
+Bug: https://bugs.gentoo.org/870250
+Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c4226f5be4..bec6ddbf62 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -252,7 +252,7 @@ AS_IF([test "x$enable_java" != "xno"], [
+ dnl if we found everything we need, set ax_java_support for the
+ dnl status message and set X_JNI for use in Makefile
+ AS_IF([test "x$JNI_CPPFLAGS" != x && test "x$ANT_FOUND" != x && test "x$JAVA" != x], [ax_java_support=yes], [ax_java_support=no])
+-AM_CONDITIONAL([X_JNI],[test "x$ax_java_support" == "xyes"])
++AM_CONDITIONAL([X_JNI],[test "x$ax_java_support" = "xyes"])
+
+ AC_CONFIG_COMMANDS([tsk/tsk_incs.h],
+ [echo "#ifndef _TSK_INCS_H" > tsk/tsk_incs.h
diff --git a/app-forensics/sleuthkit/sleuthkit-4.12.0.ebuild b/app-forensics/sleuthkit/sleuthkit-4.12.0.ebuild
index bca5e7d4bd6a..774fb6e6da83 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.12.0.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.12.0.ebuild
@@ -76,6 +76,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.1.0-tools-shared-libs.patch
"${FILESDIR}"/${PN}-4.6.4-default-jar-location-fix.patch
"${FILESDIR}"/${PN}-4.10.1-exclude-usr-local.patch
+ "${FILESDIR}"/${PN}-4.12.0-configure-ac-test-fix.patch
)
src_unpack() {