summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 23:18:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:33:07 +0100
commit815909f0ea4fb03f9ce91e8738e84843c574bb50 (patch)
treed1f9fe5e223e8bc144525bc1c53a01709443908d /app-forensics/galleta/galleta-20040505_p1.ebuild
parentapp-forensics/rifiuti: Port to EAPI 6 (diff)
downloadgentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.tar.gz
gentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.tar.bz2
gentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.zip
app-forensics/galleta: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-forensics/galleta/galleta-20040505_p1.ebuild')
-rw-r--r--app-forensics/galleta/galleta-20040505_p1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/app-forensics/galleta/galleta-20040505_p1.ebuild b/app-forensics/galleta/galleta-20040505_p1.ebuild
index 890ad5ab0d30..9192b6bdb8cb 100644
--- a/app-forensics/galleta/galleta-20040505_p1.ebuild
+++ b/app-forensics/galleta/galleta-20040505_p1.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
MY_P=${PN}_${PV/_p/_}
+
DESCRIPTION="IE Cookie Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- cd src
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
+src_configure() {
+ tc-export CC
}
src_install() {
- dodoc Readme.txt
- dobin src/galleta
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
}