summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-08-19 11:28:59 +0200
committerUlrich Müller <ulm@gentoo.org>2024-08-19 11:29:45 +0200
commit86c97fae9b13dc0b18c0d6f8473216b802d10918 (patch)
tree0d1a44fa694a92e16c2b25b0c07a5715e45e4635 /app-emacs
parentsys-devel/bpf-toolchain: unkeyword 14.2.0-r2 for -* (diff)
downloadgentoo-86c97fae9b13dc0b18c0d6f8473216b802d10918.tar.gz
gentoo-86c97fae9b13dc0b18c0d6f8473216b802d10918.tar.bz2
gentoo-86c97fae9b13dc0b18c0d6f8473216b802d10918.zip
app-emacs/zenburn-theme: new package, add 2.7.0
Bug: https://bugs.gentoo.org/937910 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/zenburn-theme/Manifest1
-rw-r--r--app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el1
-rw-r--r--app-emacs/zenburn-theme/metadata.xml20
-rw-r--r--app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild33
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/zenburn-theme/Manifest b/app-emacs/zenburn-theme/Manifest
new file mode 100644
index 000000000000..2a38b0f0c4ef
--- /dev/null
+++ b/app-emacs/zenburn-theme/Manifest
@@ -0,0 +1 @@
+DIST zenburn-emacs-2.7.0.tar.gz 122812 BLAKE2B 2c5698de664dfbd1623f6f8358214cc4458323784e94cdd9c2d7ea47231466c984bf4b0399db4705be8acab53fb2ee1c30f7ae9f2b53f9a2bc825a9f19bb9a95 SHA512 4c125e19c2c223b7eb678be261d2e1240d9269c155ad5adc432e268c12b82c4610b09fd896c9d45361def8f132dcb45c0e46728f6ffb1f0181267b44fb5927e8
diff --git a/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el b/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el
new file mode 100644
index 000000000000..002aaf546293
--- /dev/null
+++ b/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'custom-theme-load-path "@SITEETC@")
diff --git a/app-emacs/zenburn-theme/metadata.xml b/app-emacs/zenburn-theme/metadata.xml
new file mode 100644
index 000000000000..3e64e22fe991
--- /dev/null
+++ b/app-emacs/zenburn-theme/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Zenburn for Emacs is a direct port of the popular Zenburn theme
+ for vim, developed by Jani Nurminen. It's my personal belief (and that
+ of its many users I presume) that it's one of the best low contrast
+ color themes out there and that it is exceptionally easy on the eyes.
+ Zenburn is a low-contrast color theme. It's easy for your eyes and
+ designed to keep you in the zone for long programming sessions.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">bbatsov/zenburn-emacs</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild b/app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild
new file mode 100644
index 000000000000..4b8491dc0111
--- /dev/null
+++ b/app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+MY_PN="${PN%-*}-emacs"
+DESCRIPTION="Zenburn color theme for Emacs"
+HOMEPAGE="https://github.com/bbatsov/zenburn-emacs"
+SRC_URI="https://github.com/bbatsov/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins zenburn-theme.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md
+ dodoc -r screenshots
+ docompress -x /usr/share/doc/${PF}/screenshots
+
+ local DOC_CONTENTS="To enable zenburn by default, initialise it
+ in your ~/.emacs:
+ \n\t(load-theme 'zenburn 'no-confirm)"
+ readme.gentoo_create_doc
+}