summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-10 20:40:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-10 20:49:23 +0200
commit64ccb2030d0545ce42e3adde049c6413967f99c2 (patch)
tree6e7ecc2adabd3dcef5a4de83d2d7784da35d603f /app-emacs/treemacs
parentapp-emacs/po-mode: bump to 0.21.1 (diff)
downloadgentoo-64ccb2030d0545ce42e3adde049c6413967f99c2.tar.gz
gentoo-64ccb2030d0545ce42e3adde049c6413967f99c2.tar.bz2
gentoo-64ccb2030d0545ce42e3adde049c6413967f99c2.zip
app-emacs/treemacs: bump to 3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/treemacs')
-rw-r--r--app-emacs/treemacs/Manifest1
-rw-r--r--app-emacs/treemacs/treemacs-3.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index 1ff141dac693..f29e359e8b6e 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -1,3 +1,4 @@
DIST treemacs-2.10.tar.gz 4137468 BLAKE2B 0f832d02f8b0f96f7000c57b1842319155face5cb50c44ff4286f7f28dd74b38739079de9c387dbddbf93af37a5c750c45a598100ed5053674a565b4ec34f0c6 SHA512 9326a3f66c1b38eb7ef39e90900c2ef71d20c6c3478213f61c144ca4face562dccf00d6d400315c264627468a0c3319a24f0ec6cddb795b54e1b7f3c235d1c71
DIST treemacs-2.9.5.tar.gz 4134227 BLAKE2B 1fbdb278e9524fdb14cbc7699bc787ab694b00d37a91ec3e91e106079bc02f6b8b39207608873d45c70fd6355a22553bf1a0636a948b79df77adfe0b4a3f799f SHA512 adc026d7ad459418fae531c5a1a7df7f9308e63dec82240c1c5e278eb00fdf8d6dff1ee2112ea73d5a05c4266efe24623bb84f8819a6f07fbb4fde6e644ca9ad
DIST treemacs-3.0.tar.gz 4552082 BLAKE2B d12dff7aa667916ba586dcf47d642b36987ec1612a5dd276a513eef551c7b81a463d55531dacc48eac49ffc7390b1dd48a7e07285d188d4d40e779b9bc0b09f5 SHA512 981eb40973c86aec683ad6f0436c853e9254bfa10e77a60d3c36ef8b18d76dce358d68dee06355e63b4040c816e4f0064a3e722a414db0f9d3d007e5d252d753
+DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
diff --git a/app-emacs/treemacs/treemacs-3.1.ebuild b/app-emacs/treemacs/treemacs-3.1.ebuild
new file mode 100644
index 000000000000..de552c5b30b2
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit elisp distutils-r1
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.5-tests.patch
+ "${FILESDIR}"/${PN}-async-scripts.patch
+ "${FILESDIR}"/${PN}-icons-icon-directory.patch
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i src/elisp/${PN}-icons.el \
+ -i src/elisp/${PN}-async.el || die
+}
+
+python_compile() {
+ python_optimize "${S}"/src/scripts
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_test() {
+ buttercup ${BYTECOMPFLAGS} -L test --traceback full || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto ${SITEETC}/${PN}
+ doins -r icons
+ doins -r src/scripts
+}