summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/popwin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/popwin')
-rw-r--r--app-emacs/popwin/Manifest1
-rw-r--r--app-emacs/popwin/files/50popwin-gentoo.el6
-rw-r--r--app-emacs/popwin/metadata.xml11
-rw-r--r--app-emacs/popwin/popwin-0.6.2.ebuild23
4 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/popwin/Manifest b/app-emacs/popwin/Manifest
new file mode 100644
index 000000000000..a6e406923460
--- /dev/null
+++ b/app-emacs/popwin/Manifest
@@ -0,0 +1 @@
+DIST popwin-0.6.2.tar.gz 16821 SHA256 77069e5c642ccee21788f462dc2bdc30ac4789d658585da950cf7097fa41d6e9 SHA512 3c086361d6b79d7c68583cdbfb76cfd95b6ed56883382e42a863137d93e2a64fa8dce7b7873a4c46ce04a742942dd5f16367c691be608438079555578709b108 WHIRLPOOL 2739efa75f9e88296f28ab2df93990dac5630a4e6b3a7d094fed1b0ee23066c51f2ff42301cbefec9dff132ec2ddbdab2c532bd49b6f7e20903f382d9f4aa208
diff --git a/app-emacs/popwin/files/50popwin-gentoo.el b/app-emacs/popwin/files/50popwin-gentoo.el
new file mode 100644
index 000000000000..bd00744ede00
--- /dev/null
+++ b/app-emacs/popwin/files/50popwin-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'popwin:display-buffer "popwin"
+ "Display BUFFER-OR-NAME, if possible, in a popup window, or as usual.
+This function can be used as a value of `display-buffer-function'." t)
+(autoload 'popwin:special-display-popup-window "popwin"
+ "The `special-display-function' with a popup window.")
diff --git a/app-emacs/popwin/metadata.xml b/app-emacs/popwin/metadata.xml
new file mode 100644
index 000000000000..62aa791f2446
--- /dev/null
+++ b/app-emacs/popwin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+<upstream>
+ <remote-id type="github">m2ym/popwin-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/popwin/popwin-0.6.2.ebuild b/app-emacs/popwin/popwin-0.6.2.ebuild
new file mode 100644
index 000000000000..5885ce8b4144
--- /dev/null
+++ b/app-emacs/popwin/popwin-0.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Popup window manager for Emacs"
+HOMEPAGE="https://github.com/m2ym/popwin-el/"
+SRC_URI="https://github.com/m2ym/${PN}-el/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_unpack() {
+ unpack ${A}
+ mv m2ym-popwin-el-* ${P} || die
+}