summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-08 19:45:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-08 19:45:19 +0300
commit727133fa83b6a1dd172106cb584b34d98af325db (patch)
tree152ba4b2e5f231136661890e1248ddf4c62a131b /app-doc
parentdev-python/pathlib2: Stabilize 2.3.7_p1 arm, #876124 (diff)
downloadgentoo-727133fa83b6a1dd172106cb584b34d98af325db.tar.gz
gentoo-727133fa83b6a1dd172106cb584b34d98af325db.tar.bz2
gentoo-727133fa83b6a1dd172106cb584b34d98af325db.zip
app-doc/gimp-help: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0-r1.ebuild4
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0-r1.ebuild b/app-doc/gimp-help/gimp-help-2.10.0-r1.ebuild
index 9c4c1db5c92a..98bdcf4baa2b 100644
--- a/app-doc/gimp-help/gimp-help-2.10.0-r1.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,7 +28,7 @@ DEPEND="$(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
PATCHES=( "${FILESDIR}/${P}-python3.patch" )
python_check_deps() {
- has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+ python_has_version -d "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
}
src_configure() {
diff --git a/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
index 2d9bc7dd0fa5..e67cf0e86c15 100644
--- a/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
@@ -29,7 +29,7 @@ BDEPEND="
PATCHES=( "${FILESDIR}/${P}-python3.patch" )
python_check_deps() {
- has_version -b "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+ python_has_version "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
}
src_configure() {