summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-01-14 01:08:21 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-01-14 01:32:37 +0200
commita19d701b8517196aaec09d39e9542f132b3c0a0f (patch)
treec8bc424de1f640d85caedf68131334992b95615c /app-crypt
parentapp-crypt/mhash: eapi bump (diff)
downloadgentoo-a19d701b8517196aaec09d39e9542f132b3c0a0f.tar.gz
gentoo-a19d701b8517196aaec09d39e9542f132b3c0a0f.tar.bz2
gentoo-a19d701b8517196aaec09d39e9542f132b3c0a0f.zip
app-crypt/mcrypt: eapi bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mcrypt/files/mcrypt-2.6.8-format-string.patch4
-rw-r--r--app-crypt/mcrypt/files/mcrypt-2.6.8-stdlib.h.patch4
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.8-r3.ebuild32
3 files changed, 36 insertions, 4 deletions
diff --git a/app-crypt/mcrypt/files/mcrypt-2.6.8-format-string.patch b/app-crypt/mcrypt/files/mcrypt-2.6.8-format-string.patch
index d602bed46bfe..ceeb28f38e0d 100644
--- a/app-crypt/mcrypt/files/mcrypt-2.6.8-format-string.patch
+++ b/app-crypt/mcrypt/files/mcrypt-2.6.8-format-string.patch
@@ -1,5 +1,5 @@
---- src/errors.c
-+++ src/errors.c
+--- a/src/errors.c
++++ b/src/errors.c
@@ -25,24 +25,24 @@
void err_quit(char *errmsg)
diff --git a/app-crypt/mcrypt/files/mcrypt-2.6.8-stdlib.h.patch b/app-crypt/mcrypt/files/mcrypt-2.6.8-stdlib.h.patch
index 7cfae9815207..c4bdb18a6dbc 100644
--- a/app-crypt/mcrypt/files/mcrypt-2.6.8-stdlib.h.patch
+++ b/app-crypt/mcrypt/files/mcrypt-2.6.8-stdlib.h.patch
@@ -1,5 +1,5 @@
---- src/rfc2440.c 2008-11-17 06:50:01.000000000 +1100
-+++ src/rfc2440.c 2010-08-10 13:48:28.000000000 +1000
+--- a/src/rfc2440.c 2008-11-17 06:50:01.000000000 +1100
++++ b/src/rfc2440.c 2010-08-10 13:48:28.000000000 +1000
@@ -23,7 +23,7 @@
#include <zlib.h>
#endif
diff --git a/app-crypt/mcrypt/mcrypt-2.6.8-r3.ebuild b/app-crypt/mcrypt/mcrypt-2.6.8-r3.ebuild
new file mode 100644
index 000000000000..f9248dba9953
--- /dev/null
+++ b/app-crypt/mcrypt/mcrypt-2.6.8-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="replacement of the old unix crypt(1)"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-macos"
+IUSE="nls"
+
+DEPEND=">=dev-libs/libmcrypt-2.5.8
+ >=app-crypt/mhash-0.9.9
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.7-qa.patch"
+ "${FILESDIR}/${P}-stdlib.h.patch"
+ "${FILESDIR}/${P}-segv.patch"
+ "${FILESDIR}/${P}-sprintf.patch"
+ "${FILESDIR}/${P}-format-string.patch"
+ "${FILESDIR}/${P}-overflow.patch"
+)
+
+src_configure() {
+ econf $(use_enable nls)
+}