summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-04-23 14:34:17 -0500
committerSam James <sam@gentoo.org>2022-04-23 22:30:03 +0100
commit91beeccff2975bef50c7bf956242d456c67bcfdc (patch)
tree1b77b3fc8cbd242779598ef4a9feba5e113cd8dd /app-crypt/tpm2-tss
parentbase/package.use.mask: unmask tools for games-fps/eduke32 (diff)
downloadgentoo-91beeccff2975bef50c7bf956242d456c67bcfdc.tar.gz
gentoo-91beeccff2975bef50c7bf956242d456c67bcfdc.tar.bz2
gentoo-91beeccff2975bef50c7bf956242d456c67bcfdc.zip
app-crypt/tpm2-tss: add 3.1.1
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/Manifest1
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-3.1.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss/Manifest b/app-crypt/tpm2-tss/Manifest
index f8a99f762812..ea2dd7371c8c 100644
--- a/app-crypt/tpm2-tss/Manifest
+++ b/app-crypt/tpm2-tss/Manifest
@@ -1,3 +1,4 @@
DIST tpm2-tss-2.4.6.tar.gz 1472883 BLAKE2B e007de07c759e77e377f8569c0c5d94ab57597ea3cb452fb598a47c9b404714a7816c86221d4eacad962436fc7625066d4066f433cd957c37b92d51b0455e2a0 SHA512 f7f7f067605ea30661ac891e22095238689856e22e45f11a6b603cb36ed1ae0724ae52d36f0ee5dd72208da8520457667676ae08107647faa5441a0c9b642f7a
DIST tpm2-tss-3.1.0.tar.gz 1584690 BLAKE2B cee2807a030b8bab653045cb11dfc7a6a3f7b1e60c1ce4650ba5f0549f29f36ff307e7d53fb5ef9c950b4dae720bdaf35f7cd1e59ebc07b3f16740035e1d5738 SHA512 8967f172c92f1e3e5ba324dbe8afe07bf1bc7179dd755cef9812105f32634f312ee7cc7dfe8e13af69dc219432463f5dc9b93477743de47aba6af1d70b252405
+DIST tpm2-tss-3.1.1.tar.gz 1592495 BLAKE2B 0f021516700ca14a1c987d7078f1402eb2a6e2f7fc325df3ace3bd9104fe5a2211aa335af0b7f05f5e0d8c2038e0033ba498551021fa2fb5947c213813ef8796 SHA512 3010a32be2d41c2f2e06c2b745a18b3f36aaa0aec7568361902deed26779e8f76c84076ceb2a9447df8194cfc9d3b50116b7311d51d83d63037dbdca60c1384e
DIST tpm2-tss-3.2.0.tar.gz 1629211 BLAKE2B a89aa4d89a50bdfb5a9652874d30e2138747bd022049f2be2d0b56e296329d0c41254033ec3a062dbd64fde54a62e952f54446c551e5788231827cd53fae045a SHA512 cabb411f074dfa94919ba914849aac77a0ac2f50622e28a1406cf575369148774748e0e2b7a7c566ec83561a96d4b883bac5a3b1763f4cf48668a0c5d68c0a23
diff --git a/app-crypt/tpm2-tss/tpm2-tss-3.1.1.ebuild b/app-crypt/tpm2-tss/tpm2-tss-3.1.1.ebuild
new file mode 100644
index 000000000000..7d2a404b0018
--- /dev/null
+++ b/app-crypt/tpm2-tss/tpm2-tss-3.1.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info multilib-minimal tmpfiles udev
+
+DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc +fapi +openssl mbedtls static-libs test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="^^ ( mbedtls openssl )
+ fapi? ( openssl !mbedtls )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ fapi? ( dev-libs/json-c:=[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ test? ( app-crypt/swtpm
+ dev-libs/uthash
+ dev-util/cmocka
+ fapi? ( net-misc/curl ) )"
+BDEPEND="sys-apps/acl
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.0-Dont-run-systemd-sysusers-in-Makefile.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~TCG_TPM
+ "
+ linux-info_pkg_setup
+ kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
+}
+
+src_prepare() {
+ default
+
+ # See bug #833887 (and similar); eautoreconf means .pc file gets wrong version.
+ sed -i \
+ "s/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/" \
+ "configure.ac" || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable fapi) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable test unit) \
+ $(multilib_native_use_enable test integration) \
+ $(multilib_native_use_enable test self-generated-certificate) \
+ --disable-defaultflags \
+ --disable-weakcrypto \
+ --with-crypto="$(usex mbedtls mbed ossl)" \
+ --with-runstatedir=/run \
+ --with-udevrulesdir="$(get_udevdir)/rules.d" \
+ --with-udevrulesprefix=60- \
+ --with-sysusersdir="/usr/lib/sysusers.d" \
+ --with-tmpfilesdir="/usr/lib/tmpfiles.d"
+}
+
+multilib_src_install() {
+ default
+
+ if [[ ${PV} != $(sed -n -e 's/^Version: //p' "${ED}/usr/$(get_libdir)/pkgconfig/tss2-sys.pc" || die) ]] ; then
+ # Safeguard for bug #833887
+ die "pkg-config file version doesn't match ${PV}! Please report a bug!"
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process tpm2-tss-fapi.conf
+ udev_reload
+}