summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-14 14:35:31 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:39 +0000
commitbb2f8fa8fa7541defbcdb9b66049833f15c66686 (patch)
tree6fe3b2c266f0718bb60152844acd71eb1c81e1be /app-crypt/rhash
parentdev-libs/libxml2: fix build with lld-16 (diff)
downloadgentoo-bb2f8fa8fa7541defbcdb9b66049833f15c66686.tar.gz
gentoo-bb2f8fa8fa7541defbcdb9b66049833f15c66686.tar.bz2
gentoo-bb2f8fa8fa7541defbcdb9b66049833f15c66686.zip
app-crypt/rhash: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/rhash')
-rw-r--r--app-crypt/rhash/rhash-1.4.2.ebuild11
-rw-r--r--app-crypt/rhash/rhash-1.4.3.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/app-crypt/rhash/rhash-1.4.2.ebuild b/app-crypt/rhash/rhash-1.4.2.ebuild
index 28eb73baa382..85a78659e4d4 100644
--- a/app-crypt/rhash/rhash-1.4.2.ebuild
+++ b/app-crypt/rhash/rhash-1.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Console utility and library for computing and verifying file hash sums"
HOMEPAGE="http://rhash.sourceforge.net/"
@@ -46,6 +46,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
set -- \
./configure \
--target="${CHOST}" \
diff --git a/app-crypt/rhash/rhash-1.4.3.ebuild b/app-crypt/rhash/rhash-1.4.3.ebuild
index 3836fca5035c..1cfc029f4978 100644
--- a/app-crypt/rhash/rhash-1.4.3.ebuild
+++ b/app-crypt/rhash/rhash-1.4.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Console utility and library for computing and verifying file hash sums"
HOMEPAGE="http://rhash.sourceforge.net/"
@@ -42,6 +42,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
set -- \
./configure \
--target="${CHOST}" \