summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-11-02 19:09:49 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2023-02-18 14:57:18 -0700
commit9552d436d29fb6c0eee8d16da97ad0469dc1716b (patch)
tree85b34ca229f35b8042d7af579f4b36b2a21e9ff2 /app-crypt/kbfs
parentdev-cpp/sdbus-c++: Really fix musl with __UAPI_DEF_ETHHDR (diff)
downloadgentoo-9552d436d29fb6c0eee8d16da97ad0469dc1716b.tar.gz
gentoo-9552d436d29fb6c0eee8d16da97ad0469dc1716b.tar.bz2
gentoo-9552d436d29fb6c0eee8d16da97ad0469dc1716b.zip
app-crypt/kbfs: new package, add 6.0.2, 9999
Closes: https://github.com/gentoo/gentoo/pull/27372 Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'app-crypt/kbfs')
-rw-r--r--app-crypt/kbfs/Manifest2
-rw-r--r--app-crypt/kbfs/kbfs-6.0.2.ebuild67
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild67
-rw-r--r--app-crypt/kbfs/metadata.xml19
4 files changed, 155 insertions, 0 deletions
diff --git a/app-crypt/kbfs/Manifest b/app-crypt/kbfs/Manifest
new file mode 100644
index 000000000000..084c14bbd06a
--- /dev/null
+++ b/app-crypt/kbfs/Manifest
@@ -0,0 +1,2 @@
+DIST kbfs-6.0.2-deps.tar.xz 205729260 BLAKE2B d58d1b6615c9195ad3b4eb82bbbb3f3ff4729683b6d4b69dd35222089fa9477710a59c75af830a4f74ca6ccf3eae2fe6d880a72b74d15478fe29db268f333f64 SHA512 39afab3647ea766ed86059548eddc910195ec39b71897a92cdc927d9c0025297254950c0a85434ce9a1e90a189b6f84504445e1d6152ec4bd8441dd55ae4e6c0
+DIST kbfs-6.0.2.tar.gz 57283593 BLAKE2B 272dd3c9e2e855e1979a620f5a600cb1352632fca055ba36140d2cc63013e8f8b7e66c5f9fe74ab2c71dac2df7cc27aac9a8387f7444eff4c469659ff1aece2e SHA512 0a3fe3f8b9fc7a3099696699268bec54aed898d0692a3033e54f816b87ef2616b83a0817d365b87a77ecb489ae5d11bae15597c3bcd23819422ec384ae63f6a0
diff --git a/app-crypt/kbfs/kbfs-6.0.2.ebuild b/app-crypt/kbfs/kbfs-6.0.2.ebuild
new file mode 100644
index 000000000000..b43cf2f164e1
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-6.0.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/keybase/client.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~nicolasbock/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse:0=
+"
+
+src_unpack() {
+ default
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ GOMODCACHE="${S}/go/go-mod"
+ pushd "${S}/go" || die
+ ego mod download
+ popd || die
+ else
+ ln -vs "client-${PV}" "${P}" || die
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
+ fi
+}
+
+src_compile() {
+ pushd ./go/kbfs/kbfsfuse || die
+ ego build -tags production -o "${T}/kbfsfuse"
+ popd || die
+ pushd ./go/kbfs/kbfsgit/git-remote-keybase || die
+ ego build -tags production -o "${T}/git-remote-keybase"
+ popd || die
+ pushd ./go/kbfs/redirector || die
+ ego build -tags production -o "${T}/keybase-redirector"
+ popd || die
+}
+
+src_test() {
+ pushd ./go/kbfs/kbfsfuse || die
+ ego test
+ popd || die
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ dobin "${T}/git-remote-keybase"
+ dobin "${T}/keybase-redirector"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
+ systemd_douserunit "${S}/packaging/linux/systemd/keybase-redirector.service"
+}
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
new file mode 100644
index 000000000000..7ebdcb88ebf8
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/keybase/client.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" ${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse:0=
+"
+
+src_unpack() {
+ default
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ GOMODCACHE="${S}/go/go-mod"
+ pushd "${S}/go" || die
+ ego mod download
+ popd || die
+ else
+ ln -vs "client-${PV}" "${P}" || die
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
+ fi
+}
+
+src_compile() {
+ pushd ./go/kbfs/kbfsfuse || die
+ ego build -tags production -o "${T}/kbfsfuse"
+ popd || die
+ pushd ./go/kbfs/kbfsgit/git-remote-keybase || die
+ ego build -tags production -o "${T}/git-remote-keybase"
+ popd || die
+ pushd ./go/kbfs/redirector || die
+ ego build -tags production -o "${T}/keybase-redirector"
+ popd || die
+}
+
+src_test() {
+ pushd ./go/kbfs/kbfsfuse || die
+ ego test
+ popd || die
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ dobin "${T}/git-remote-keybase"
+ dobin "${T}/keybase-redirector"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
+ systemd_douserunit "${S}/packaging/linux/systemd/keybase-redirector.service"
+}
diff --git a/app-crypt/kbfs/metadata.xml b/app-crypt/kbfs/metadata.xml
new file mode 100644
index 000000000000..4ce1f52b1ca5
--- /dev/null
+++ b/app-crypt/kbfs/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>ran.dall@icloud.com</email>
+ <name>Randall T. Vasquez</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ The official Keybase implementation of the client-side code for the
+ Keybase filesystem (KBFS), a cryptographically secure filesystem.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keybase/client</remote-id>
+ </upstream>
+</pkgmetadata>