summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/aespipe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/Manifest2
-rw-r--r--app-crypt/aespipe/aespipe-2.3e.ebuild30
-rw-r--r--app-crypt/aespipe/aespipe-2.4c-r1.ebuild29
-rw-r--r--app-crypt/aespipe/metadata.xml10
4 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/aespipe/Manifest b/app-crypt/aespipe/Manifest
new file mode 100644
index 000000000000..8816155839ec
--- /dev/null
+++ b/app-crypt/aespipe/Manifest
@@ -0,0 +1,2 @@
+DIST aespipe-v2.3e.tar.bz2 91752 SHA256 4e63a5709fdd0bffdb555582f9fd7a0bd1842e429420159accaf7f60c5d3c70f SHA512 e62f1f7a8f595066142f626dfd928106b4057c3e5f129bb31057af4e4a9412b4def60afffac72083621334449d627424fb661ef11a426015b0b0c232aa3ce648 WHIRLPOOL 3564aedeeb7e16a9cf10ceb13d15aaf3350b39ff8eb771d23d59029c8676b27bccee4098644d7e3d457af6866e045bec1cdfdf16f3941a831c0ec0b90897d08a
+DIST aespipe-v2.4c.tar.bz2 106608 SHA256 260190beea911190a839e711f610ec3454a9b13985d35479775b7e26ad4c845e SHA512 6738c019e4c1e5377650f9a982b328ce38e127ebe838cfe61c7d3fad878eaf0a4fd051d32897eb4c2ff33f94669203ccba25fc246405b50f9ac24fdf5d2831cf WHIRLPOOL a9c99f45313fa427e3a4227a3a8b8035c031937851e30fb5a31e8409bef25990497ce3f1b32e0e93c184a6d5549fa2a5e31185790a531350d6774df041c6f5e9
diff --git a/app-crypt/aespipe/aespipe-2.3e.ebuild b/app-crypt/aespipe/aespipe-2.3e.ebuild
new file mode 100644
index 000000000000..9bef38d6d18c
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.3e.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="static"
+DEPEND=""
+RDEPEND="app-arch/sharutils"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dobin aespipe bz2aespipe
+ dodoc README
+ doman aespipe.1
+}
diff --git a/app-crypt/aespipe/aespipe-2.4c-r1.ebuild b/app-crypt/aespipe/aespipe-2.4c-r1.ebuild
new file mode 100644
index 000000000000..62ceb09ad12c
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4c-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+DEPEND=""
+RDEPEND="app-arch/sharutils
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}
diff --git a/app-crypt/aespipe/metadata.xml b/app-crypt/aespipe/metadata.xml
new file mode 100644
index 000000000000..7e01eb4b56dd
--- /dev/null
+++ b/app-crypt/aespipe/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<use>
+ <flag name='asm'>Enable assebly modules</flag>
+ <flag name='cpu_flags_x86_padlock'>Use VIA padlock instructions,
+ detected at run time, code still works on non-padlock processors</flag>
+</use>
+</pkgmetadata>