summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-12 14:08:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-12 14:35:29 +0200
commit9af347fdd733c88ff8b9724f378ba57bb725419c (patch)
tree3848cf51d0ddab46954f4e4e2b51c085f77a2745 /app-containers
parentapp-containers/devcontainer: drop old 0.60.0 (diff)
downloadgentoo-9af347fdd733c88ff8b9724f378ba57bb725419c.tar.gz
gentoo-9af347fdd733c88ff8b9724f378ba57bb725419c.tar.bz2
gentoo-9af347fdd733c88ff8b9724f378ba57bb725419c.zip
app-containers/devcontainer: bump to 0.66.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.66.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 28e6bc7da0a5..b306b3912d20 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,3 +1,4 @@
DIST devcontainer-0.62.0.tgz 619481 BLAKE2B 69dc4a1b872c9afe4b3ef631f4626973523956c85e192fe1bbaf3930a836aa02c1caf51739a235869cfb67c0628de64069eab8e59a41da70f97c2f3e1d16de16 SHA512 dae5013c13df36ea0f7073a23b7484c8a5261f84bba9a8ed16b094ad89e8d3a9527922dfc43feb7a72a6f172ca9d89197bd05e29172ba433338f3365cf4e9852
DIST devcontainer-0.64.0.tgz 619776 BLAKE2B 99c5fa724915f107f99d629cef86eff3635bf1a66fedfabd26cef8d83588e609fa9ba51d1264a921c03c4a938302ef3d874a2234904f23da38bc72ddd43c13f8 SHA512 6caea7759074b48760b22bb127feb2d18ae88b7d826f2e4e703de3c0680cbe98ecf0a936b76e80c4a20ab446ca60851e4446e4474fcac62969722260ff474c6f
DIST devcontainer-0.65.0.tgz 620002 BLAKE2B 4b48365c5d717c0d675256822864677678cd6260e7e8875cbec996f9fa1186d6085e0c394a39fa5c098787245008b5f438adead4eedf81ba3c93b01e6ee3b9c6 SHA512 ed73dc870df518c29d67dd25d15b1aa7e328b83e1fcb40daee3c96f7b036a410e75e7a4e0319bb963dacff68af6d8ccef49d4555e70f6837bd665a2b8a589373
+DIST devcontainer-0.66.0.tgz 620063 BLAKE2B f63fdd8dc5aa9de094e0e31e345fadfd9f4f9cd720c11c597aa0ac0ec7b28b0663bbecfe43b374d1c163a7a61d92865d8285663a8ff0e517c01946608574c3ab SHA512 fac309084ea6d5456150827a4120e8c20a14b82619d56f1f8c1750c917cccc1065f12a7e3b804cab8f7685d21a10a4aa59ef765764c0620dac40fc0d1a519904
diff --git a/app-containers/devcontainer/devcontainer-0.66.0.ebuild b/app-containers/devcontainer/devcontainer-0.66.0.ebuild
new file mode 100644
index 000000000000..991cd956e37b
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.66.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}