summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2019-05-23 05:55:39 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-08-08 21:21:15 +0300
commit70ab4e4e37a23720a608fbeed7ca2e3f416fe36c (patch)
tree975a9f4441bfe4694290ba93ffce9a827fc4a90e /app-arch/upx
parentdev-libs/roct-thunk-interface: do not install Linux kernel headers (diff)
downloadgentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.tar.gz
gentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.tar.bz2
gentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.zip
app-arch/upx: updated to 3.95
Updated to recent version 3.95 (#645646), removed -Werror option (#618432). Major cleanups to ebuild: * Updated to EAPI 7 * Updated HOMEPAGE, removed redundant USEs * Added myself to maintainers Closes: https://bugs.gentoo.org/618432 Closes: https://bugs.gentoo.org/645646 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest1
-rw-r--r--app-arch/upx/metadata.xml9
-rw-r--r--app-arch/upx/upx-3.95.ebuild34
3 files changed, 41 insertions, 3 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index c31e4a5d396c..d6869e48f9b5 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1,2 +1,3 @@
DIST lzma465.tar.bz2 288122 BLAKE2B 93fa080e6539bef79d8d0baff781b9e41329f649724991f608cfa9ee651e79b20cf38d27efa96fe848e61111ff355f58dfde81f0743e1d5f0d701d72e512c70d SHA512 690f005cfa9d3a65db03baddad57cf8dd79f861ac72d2e1bc18a151f3673d5f8043e3331f5dc3fba713dfd7b01ebf0817a2c0b6a1b22e1f7d8255a42b85ea4ac
DIST upx-3.91-src.tar.bz2 904747 BLAKE2B e9888368e5ddb62dc3cf14bd39a6101c31621c9a1ce2529957cb5c96bd70845db01a2e2f73a5b64dd7b33c9e18679f8e134fffdea41bc5b3663ff350c6de3a6c SHA512 7e9a392fe11daf7baf9632f2c448ef9936da7dfab215f86ba417e9f097770949acb653aaabe6cc5ed812efc486cb35e0c1e128c80026b02825713d8b12251cf5
+DIST upx-3.95-src.tar.xz 790776 BLAKE2B e7e5e24ba3675ab9f9f3daa36d6d3f00b6af614c2ca64c4d185a065afcdc02373ccf0200f7116ebbfaa1f9b961078f40296b1c716eca80aba86e95d6a9463b99 SHA512 0e1d3e26462057f16587197e73301957e870107808fdbcd24d9976094dfa0e5efbe8da0f9b6732a99f05990dcd4be242a87ea19a7110dc052c6dc982cd596416
diff --git a/app-arch/upx/metadata.xml b/app-arch/upx/metadata.xml
index a9b5374e66fe..f0670e9f6972 100644
--- a/app-arch/upx/metadata.xml
+++ b/app-arch/upx/metadata.xml
@@ -1,9 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>UPX is a versatile executable packer with a excellent compression ratio</longdescription>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
<upstream>
- <remote-id type="sourceforge">sevenzip</remote-id>
+ <remote-id type="github">upx/upx</remote-id>
</upstream>
+ <longdescription>UPX is a versatile executable packer with a excellent compression ratio</longdescription>
</pkgmetadata>
diff --git a/app-arch/upx/upx-3.95.ebuild b/app-arch/upx/upx-3.95.ebuild
new file mode 100644
index 000000000000..f0ea16873abd
--- /dev/null
+++ b/app-arch/upx/upx-3.95.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}