summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-04-11 10:56:41 +0300
committerYixun Lan <dlan@gentoo.org>2024-04-11 22:16:03 +0000
commit2e008146b10858f3e68c5b3d599f307828364447 (patch)
treea5ae84e1163d4a6c4e887ea9d1e2f7c44b9f718e /app-arch/upx
parentapp-text/cmark: fix test failures (diff)
downloadgentoo-2e008146b10858f3e68c5b3d599f307828364447.tar.gz
gentoo-2e008146b10858f3e68c5b3d599f307828364447.tar.bz2
gentoo-2e008146b10858f3e68c5b3d599f307828364447.zip
app-arch/upx: add 4.2.3
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest1
-rw-r--r--app-arch/upx/upx-4.2.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index 889517f1db6f..9ee4e17b347d 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1,2 +1,3 @@
DIST upx-4.1.0-src.tar.xz 1267708 BLAKE2B ef7884028a97b1d7e542fc27756b705582786a22d193b1eef40d0db16580958baddc3baa44429b5ba2c0f7b5d4d0f4f79fdeb777af016b962b07c7639a319090 SHA512 de8306e833198d7f470c050b05c6111a50ea94f2e757c1006433742871ccd93fd7412f942cd776e9eac6c91e379545d72f070f3fe928e75e5d5092b766474f8c
DIST upx-4.2.2-src.tar.xz 1275320 BLAKE2B 747d8e9543325cafd368d5b47e7a90bfef042a80a58ad0fc1eba798716cebe16ef91645e436fd9506a3c8fe58aa28852437a81e4058afbb213284a4a2475c828 SHA512 03885abfd1db899ea21e9469068dbe046e4817de461e36a6c8a77f6a98f8ccaf00c95846ad3b13e59a5e037ce2f2bed7bea599396968e0aeb7ba5fce1b374a9b
+DIST upx-4.2.3-src.tar.xz 1283824 BLAKE2B 2b53bf68196c35c05eb930760ad20446fbcde9b15e1e9261e2eb7553dc1c8ede48db952cd7c5bc6de5861ac98f9f62bb1d348806731fea7dad1e532fc7e1e636 SHA512 b9ebda5d3372132bb861e0dd035829b16e4c06900f68af182895f17975493707d78cbabc63060e581de1ce149bb5129d883f6e6abcde0413c0bf474db919f5fd
diff --git a/app-arch/upx/upx-4.2.3.ebuild b/app-arch/upx/upx-4.2.3.ebuild
new file mode 100644
index 000000000000..83d85276513a
--- /dev/null
+++ b/app-arch/upx/upx-4.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_GITREV=ON
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ -DUPX_CONFIG_CMAKE_DISABLE_TEST=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
+}