summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/deltarpm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/deltarpm')
-rw-r--r--app-arch/deltarpm/Manifest1
-rw-r--r--app-arch/deltarpm/deltarpm-3.6_pre20110223-r1.ebuild51
-rw-r--r--app-arch/deltarpm/files/3.6_pre20110223-build.patch13
-rw-r--r--app-arch/deltarpm/metadata.xml11
4 files changed, 76 insertions, 0 deletions
diff --git a/app-arch/deltarpm/Manifest b/app-arch/deltarpm/Manifest
new file mode 100644
index 000000000000..989530b1e289
--- /dev/null
+++ b/app-arch/deltarpm/Manifest
@@ -0,0 +1 @@
+DIST deltarpm-git-20110223.tar.bz2 499623 SHA256 e4d6cad74cece0c6e48d5c49929e00a23ba116ff88a09245ad1d7ac84610c089 SHA512 ca6b75d9be5fc74206c57d6d13fe207f92e5dd295a75aee9690d171bcff877f6b04fe4f52e3f919e7ef0045087c39a63a773886d6c79977a16fe2791052a549c WHIRLPOOL c9a7f114f872bd142545edc902cf38a0b23c945eaa8dadda037a10f06811db99ea7c74f4f236dbaf59542c02409e3ffec814bdc930120d9aa47dfeface6d09aa
diff --git a/app-arch/deltarpm/deltarpm-3.6_pre20110223-r1.ebuild b/app-arch/deltarpm/deltarpm-3.6_pre20110223-r1.ebuild
new file mode 100644
index 000000000000..082f90e9348d
--- /dev/null
+++ b/app-arch/deltarpm/deltarpm-3.6_pre20110223-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils toolchain-funcs python-single-r1
+
+SNAPSHOT="20110223"
+
+DESCRIPTION="tools to create and apply deltarpms"
+HOMEPAGE="http://gitorious.org/deltarpm/deltarpm"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${PN}-git-${SNAPSHOT}.tar.bz2/70f8884be63614ca7c3fc888cf20ebc8/${PN}-git-${SNAPSHOT}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND="sys-libs/zlib
+ app-arch/xz-utils
+ app-arch/bzip2
+ <app-arch/rpm-5
+ python? ( ${PYTHON_DEPS} )"
+DEPEND=${RDEPEND}
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S="${WORKDIR}/${PN}-git-${SNAPSHOT}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^prefix/s:/local::' \
+ -e '/^mandir/s:/man:/share/man:' \
+ Makefile || die
+ epatch "${FILESDIR}/3.6_pre20110223-build.patch"
+}
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+
+ if use python; then
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" python
+ fi
+}
diff --git a/app-arch/deltarpm/files/3.6_pre20110223-build.patch b/app-arch/deltarpm/files/3.6_pre20110223-build.patch
new file mode 100644
index 000000000000..c7feea74f893
--- /dev/null
+++ b/app-arch/deltarpm/files/3.6_pre20110223-build.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 0d0028f..9d05d59 100644
+--- a/Makefile
++++ b/Makefile
+@@ -41,7 +41,7 @@ _deltarpmmodule.so: readdeltarpm.o rpmhead.o util.o md5.o cfile.o $(zlibbundled)
+ if [ ! -f "python$$PYVER/$@" ]; then \
+ mkdir -p python$$PYVER ;\
+ $(CC) $(CFLAGS) $$PYCFLAGS $(zlibcppflag) -fPIC -c -o python$$PYVER/deltarpmmodule.o deltarpmmodule.c ;\
+- $(CC) -o python$$PYVER/$@ python$$PYVER/deltarpmmodule.o $^ -shared -Wl,-soname,_deltarpmmodule.so $(LDLIBS) $$PYLDFLAGS; \
++ $(CC) -o python$$PYVER/$@ python$$PYVER/deltarpmmodule.o $^ -shared -Wl,-soname,_deltarpmmodule.so $(LDLIBS) $(LDFLAGS) $$PYLDFLAGS; \
+ fi; \
+ fi; \
+ done
diff --git a/app-arch/deltarpm/metadata.xml b/app-arch/deltarpm/metadata.xml
new file mode 100644
index 000000000000..24ef88ea5b33
--- /dev/null
+++ b/app-arch/deltarpm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A tool to create and apply deltarpms.</longdescription>
+ <upstream>
+ <remote-id type="gitorious">deltarpm/deltarpm</remote-id>
+ </upstream>
+</pkgmetadata>