summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/arc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/arc')
-rw-r--r--app-arch/arc/Manifest1
-rw-r--r--app-arch/arc/arc-5.21p.ebuild35
-rw-r--r--app-arch/arc/files/arc-5.21m-darwin.patch11
-rw-r--r--app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch12
-rw-r--r--app-arch/arc/files/arc-5.21o-interix.patch12
-rw-r--r--app-arch/arc/metadata.xml11
6 files changed, 82 insertions, 0 deletions
diff --git a/app-arch/arc/Manifest b/app-arch/arc/Manifest
new file mode 100644
index 000000000000..c873b2daba44
--- /dev/null
+++ b/app-arch/arc/Manifest
@@ -0,0 +1 @@
+DIST arc-5.21p.tar.gz 84791 SHA256 eacf870a245f155a4ba8c6f8e0fbb2e8a267aafa157f56ba7a8cb1d74fd8b5a1 SHA512 c70c01ec407cc27f6507e2715d8b553277609cb49369a1e65a83d007362a24b69bb09ef2bf168ee36ca6797bd4524644a89e9114d866351ae53fece193c2967c WHIRLPOOL 307cb7fc3b3760f39c2746ba755f256bfebe615159dc0f4401ea8e54560d8c8d17610731a8475e8c9497d52341012a8c13f14737f89847bb7d78fa2cc2c42a8b
diff --git a/app-arch/arc/arc-5.21p.ebuild b/app-arch/arc/arc-5.21p.ebuild
new file mode 100644
index 000000000000..6c8ed4484b3b
--- /dev/null
+++ b/app-arch/arc/arc-5.21p.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create & extract files from DOS .ARC files"
+HOMEPAGE="http://arc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P/p/m}-darwin.patch \
+ "${FILESDIR}"/${P/p/m}-gentoo-fbsd.patch \
+ "${FILESDIR}"/${P/p/o}-interix.patch
+ sed -i Makefile \
+ -e 's/CFLAGS = $(OPT) $(SYSTEM)/CFLAGS += $(SYSTEM)/' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin arc marc
+ doman arc.1
+ dodoc Arc521.doc Arcinfo Changelog Readme
+}
diff --git a/app-arch/arc/files/arc-5.21m-darwin.patch b/app-arch/arc/files/arc-5.21m-darwin.patch
new file mode 100644
index 000000000000..fb1eb5ea2598
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21m-darwin.patch
@@ -0,0 +1,11 @@
+--- arc-5.21m/tmclock.c
++++ arc-5.21m/tmclock.c
+@@ -14,7 +14,7 @@
+ /* Julian day number of the Unix* clock's origin, 01 Jan 1970. */
+ #define JD1970 2440587L
+ #define CENTURY 19
+-#if BSD
++#if BSD || defined(__MACH_O__)
+ #include <sys/time.h>
+ #else
+ #include <time.h>
diff --git a/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch b/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch
new file mode 100644
index 000000000000..552bfd14edd7
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch
@@ -0,0 +1,12 @@
+--- tmclock.c 2005-09-21 18:39:57 +0200
++++ tmclock.c.new 2007-06-16 15:58:26 +0200
+@@ -18,8 +18,10 @@
+ #include <sys/time.h>
+ #else
+ #include <time.h>
++#ifdef timezone
+ extern long timezone; /* should be in <time.h>, but isn't on Sun */
+ #endif
++#endif
+
+ long tzone; \ No newline at end of file
diff --git a/app-arch/arc/files/arc-5.21o-interix.patch b/app-arch/arc/files/arc-5.21o-interix.patch
new file mode 100644
index 000000000000..f95aee85e37d
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21o-interix.patch
@@ -0,0 +1,12 @@
+diff -ru arc-5.21o.orig/arcdos.c arc-5.21o/arcdos.c
+--- arc-5.21o.orig/arcdos.c 2008-03-30 15:44:53 +0200
++++ arc-5.21o/arcdos.c 2008-03-30 15:45:51 +0200
+@@ -30,7 +30,7 @@
+ #if UNIX
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#if BSD
++#if BSD || defined(__INTERIX)
+ #include <sys/time.h>
+ #else
+ #include <time.h> /* Sys V. Bleah. */
diff --git a/app-arch/arc/metadata.xml b/app-arch/arc/metadata.xml
new file mode 100644
index 000000000000..0e81bff44113
--- /dev/null
+++ b/app-arch/arc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A program that is able to create and extract files form the DOS .ARC file</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">arc</remote-id>
+ </upstream>
+</pkgmetadata>