summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2016-07-04 14:00:38 -0400
committerPatrice Clement <monsieurp@gentoo.org>2016-07-07 07:19:28 +0000
commitd068491162cd182e4227326322c11bf886279be1 (patch)
tree436c5fe73c2ab3ebffa6ba49c5c4474e40bb91e9 /app-admin/needrestart
parentwww-misc/urlwatch: remove old (diff)
downloadgentoo-d068491162cd182e4227326322c11bf886279be1.tar.gz
gentoo-d068491162cd182e4227326322c11bf886279be1.tar.bz2
gentoo-d068491162cd182e4227326322c11bf886279be1.zip
app-admin/needrestart: Add ebuild to the tree.
needrestart checks which daemons need to be restarted after library upgrades. It is inspired by checkrestart from the debian-goodies package. needrestart supports but does not require systemd. If systemd is not available or does not return a service name needrestart uses hooks to identify the corresponding System V init script. If a process inside a container (LXC, docker) it suggests to restart the entire container. needrestart contains a heuristic for different interpreter languages: it tries to detect if outdated script code/modules are in use (Java, Perl, Python, Ruby). Gentoo-Bug: https://bugs.gentoo.org/588010 Closes: https://github.com/gentoo/gentoo/pull/1825 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/needrestart')
-rw-r--r--app-admin/needrestart/Manifest1
-rw-r--r--app-admin/needrestart/metadata.xml18
-rw-r--r--app-admin/needrestart/needrestart-2.8.ebuild37
-rw-r--r--app-admin/needrestart/needrestart-9999.ebuild37
4 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
new file mode 100644
index 000000000000..9c2af10d3559
--- /dev/null
+++ b/app-admin/needrestart/Manifest
@@ -0,0 +1 @@
+DIST v2.8.tar.gz 46420 SHA256 33b4f734335987557c68a8c57ea070ac4d23a249fa8675260f0bc28769056cc8 SHA512 2a6e5616a412039e9057a655208a7c55ed611d0deee5ba4c1d25563bb2610bcbf2b6d2534b906fd729db2eee5b3891fdb3fd3bc647f4d6aa06e2a87173b69be7 WHIRLPOOL 4f9daf45ca1a034d6476cf0b387174665d6bf15a4f36cb86e565d6b3715227bf8f7e27f6af422b1ef53c4b07a76d7b36eea0852e2db2a9032679ecc0b04bfc15
diff --git a/app-admin/needrestart/metadata.xml b/app-admin/needrestart/metadata.xml
new file mode 100644
index 000000000000..f37a51df4ac1
--- /dev/null
+++ b/app-admin/needrestart/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ </use>
+ <longdescription lang="en">
+ Restart daemons after library updates
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/needrestart/needrestart-2.8.ebuild b/app-admin/needrestart/needrestart-2.8.ebuild
new file mode 100644
index 000000000000..40723015663d
--- /dev/null
+++ b/app-admin/needrestart/needrestart-2.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/Term-ProgressBar-Simple
+"
+DEPEND="${RDEPEND}
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}
diff --git a/app-admin/needrestart/needrestart-9999.ebuild b/app-admin/needrestart/needrestart-9999.ebuild
new file mode 100644
index 000000000000..40723015663d
--- /dev/null
+++ b/app-admin/needrestart/needrestart-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/Term-ProgressBar-Simple
+"
+DEPEND="${RDEPEND}
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}