summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-09-02 10:43:58 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-09-02 10:43:58 +0200
commitee4c951c75d643f30d7d282ad28b1c5e2c9485b2 (patch)
tree020e8525204e43964b06219804b6e186b6fd1566 /app-admin/exo
parentprofiles: unmask bind-9.18 (diff)
downloadgentoo-ee4c951c75d643f30d7d282ad28b1c5e2c9485b2.tar.gz
gentoo-ee4c951c75d643f30d7d282ad28b1c5e2c9485b2.tar.bz2
gentoo-ee4c951c75d643f30d7d282ad28b1c5e2c9485b2.zip
app-admin/exo: add 1.79.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.79.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index d4da756c9c16..0a0cd670fe4a 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.78.5.gh.tar.gz 11128614 BLAKE2B 8d22212708b961a1f40028d19487b81a5208276a08b97d70553341af1fd9dbe9e483bfc09404671536d8b56ee0b8332470faa59a0d0636e0a861572a2647d5ee SHA512 1e007920ffbd5e9df7af2bd4d679cd7bf75712f5a506ab78d9a9d61ee5790e2e01840101e40382df4212667a6e05c5564ee20b640c883ea1ff45c37dbae7a3e1
+DIST exo-1.79.0.gh.tar.gz 11129715 BLAKE2B b3f529429d448cb01b921ed1a192dfab04b396be7a0cc62152d9789369550b8aa65c1477192752a8a0943fa8e5d51518226e76a149cecd81c688633208e7f13b SHA512 e67236dde1c485578eeec50d439e6dc967bac444c4b9b84c390c6ce3546d18c65cafa3dc9b12e2bd0ca32714ddc5d0a2398dd9bf75777d302558778994d12b68
diff --git a/app-admin/exo/exo-1.79.0.ebuild b/app-admin/exo/exo-1.79.0.ebuild
new file mode 100644
index 000000000000..43fbacd8aa32
--- /dev/null
+++ b/app-admin/exo/exo-1.79.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+
+src_compile() {
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}