summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-03-31 19:23:41 +0200
committerSebastian Pipping <sping@gentoo.org>2019-03-31 19:23:41 +0200
commit920921cf9bbb459ee0e540ba20dcaac365575225 (patch)
tree012d0abd0b7128f29a380cee725b69a1c7e0acea /app-admin/checksec/checksec-1.11.1.ebuild
parentx11-misc/safeeyes: Clean old (diff)
downloadgentoo-920921cf9bbb459ee0e540ba20dcaac365575225.tar.gz
gentoo-920921cf9bbb459ee0e540ba20dcaac365575225.tar.bz2
gentoo-920921cf9bbb459ee0e540ba20dcaac365575225.zip
app-admin/checksec: 1.11.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-admin/checksec/checksec-1.11.1.ebuild')
-rw-r--r--app-admin/checksec/checksec-1.11.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/checksec/checksec-1.11.1.ebuild b/app-admin/checksec/checksec-1.11.1.ebuild
new file mode 100644
index 000000000000..15b1a89861df
--- /dev/null
+++ b/app-admin/checksec/checksec-1.11.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN=${PN}.sh
+DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.7.2-path.patch
+ eapply_user
+ sed 's,^pkg_release=false,pkg_release=true,' -i ${PN} || die
+}
+
+src_install() {
+ default
+
+ doman extras/man/*
+
+ insinto /usr/share/zsh/site-functions
+ doins extras/zsh/_${PN}
+
+ dobin ${PN}
+}