summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-05-23 23:20:29 +0000
committerYixun Lan <dlan@gentoo.org>2024-05-24 00:09:46 +0000
commit8dc2916d1c59675c1ee63f336c99eecbcc589238 (patch)
treeab0629e71a6fdf21748d3fd4191ac028d8504ad5 /app-admin/bitwarden-desktop-bin
parentdev-dotnet/fsautocomplete: drop old 0.73.0 (diff)
downloadgentoo-8dc2916d1c59675c1ee63f336c99eecbcc589238.tar.gz
gentoo-8dc2916d1c59675c1ee63f336c99eecbcc589238.tar.bz2
gentoo-8dc2916d1c59675c1ee63f336c99eecbcc589238.zip
app-admin/bitwarden-desktop-bin: add 2024.5.0
Closes: https://bugs.gentoo.org/932565 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-admin/bitwarden-desktop-bin')
-rw-r--r--app-admin/bitwarden-desktop-bin/Manifest1
-rw-r--r--app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.5.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-admin/bitwarden-desktop-bin/Manifest b/app-admin/bitwarden-desktop-bin/Manifest
index 3567b1970501..766929ac7384 100644
--- a/app-admin/bitwarden-desktop-bin/Manifest
+++ b/app-admin/bitwarden-desktop-bin/Manifest
@@ -1,3 +1,4 @@
DIST Bitwarden-2024.2.0-amd64.deb 79917282 BLAKE2B 2066dc71bed9cddbcedccfd9129e3e81ac9f8a71217d2c651fb8a067b3e318574e26104b447a7ccd6734efded64ef3620cf4a7e36f0a577ed98f5468839540cb SHA512 c9394914fd6c82096fc5336e73b539e250727c6917af97961df0bd7de241f955b9eb87da154f32972c73ea1ce59bf0d79660658277185c89e099360ec4c3ea26
DIST Bitwarden-2024.3.0-amd64.deb 80463348 BLAKE2B 668fd4c18507b349e5892e7511b4898764a33d9da0a837379c7856caa054782fbf6a3337b03a779a8c8111d2458f560b31c32856850ff931694a8f18d889bdc9 SHA512 9297367e82e76870b7f12becfca6ec3bc0ce8f6515f4e17e9830d4df599891c839a8f5990c97b684528c8a4ad1c24ddd3bc99c1552620aee84b81c1cbf115771
DIST Bitwarden-2024.4.1-amd64.deb 80470012 BLAKE2B 64b451c3fbbac303782c68a366c66c32c49d0ecb52bcbc085451157216cc99fa888941e8c911c14f6a68aa6bb0413463b4296f108386e7b5b3ca8925c6dcc871 SHA512 e6edcd84f44062ccfa4152baf7dab230915d006f7f31de0ffcbe1acb62525777c7d653a7cb7c51509fb9ebcf5ba4219df97e5128853813a54aadbfd92ff2c819
+DIST Bitwarden-2024.5.0-amd64.deb 80326102 BLAKE2B ec8e9ae52bb5dcddc8b0d6e34f18174a304766639300ef2b601c4b5c62b4fa8f2d79e38b7a383e20aee9eb45a3af24ff54d7926ca051d5f1ea3b92861539dff3 SHA512 1f54757c74e438e556c512b5b96f08b758924248aea495ef87e2e408895f05970f2a46627ef421f23d659d50510216dcecca774f4a0fd34ee87cd10bed1e1f98
diff --git a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.5.0.ebuild b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.5.0.ebuild
new file mode 100644
index 000000000000..a98f129ada65
--- /dev/null
+++ b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.5.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg-utils
+
+MY_PN="Bitwarden"
+
+DESCRIPTION="Bitwarden password manager desktop client"
+HOMEPAGE="https://bitwarden.com/"
+SRC_URI="https://github.com/bitwarden/clients/releases/download/desktop-v${PV}/Bitwarden-${PV}-amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ x11-libs/pango
+"
+IDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+"
+
+QA_PREBUILT="
+ opt/Bitwarden/*.so*
+ opt/Bitwarden/bitwarden
+ opt/Bitwarden/chrome-sandbox
+ opt/Bitwarden/chrome_crashpad_handler
+"
+
+src_install() {
+ insinto /opt
+ doins -r opt/${MY_PN}
+ fperms 755 /opt/Bitwarden/bitwarden
+ fperms 4755 /opt/Bitwarden/chrome-sandbox
+
+ domenu usr/share/applications/bitwarden.desktop
+
+ local x
+ for x in 16 32 64 128 256 512; do
+ doicon -s ${x} usr/share/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}