summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-23 04:20:51 +0000
committerSam James <sam@gentoo.org>2021-03-23 04:21:06 +0000
commit9bb0d1f17bb1ee8185b53d8be1a010e14fb89572 (patch)
treec16785d616fee75b33ab87cd5bb5586a2401b1e9 /app-admin/authbind
parentapp-admin/authbind: port to EAPI 7 (diff)
downloadgentoo-9bb0d1f17bb1ee8185b53d8be1a010e14fb89572.tar.gz
gentoo-9bb0d1f17bb1ee8185b53d8be1a010e14fb89572.tar.bz2
gentoo-9bb0d1f17bb1ee8185b53d8be1a010e14fb89572.zip
app-admin/authbind: add 2.1.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/authbind')
-rw-r--r--app-admin/authbind/Manifest1
-rw-r--r--app-admin/authbind/authbind-2.1.2.ebuild52
-rw-r--r--app-admin/authbind/files/authbind-2.1.1-respect-flags.patch2
3 files changed, 53 insertions, 2 deletions
diff --git a/app-admin/authbind/Manifest b/app-admin/authbind/Manifest
index 635a5695a648..eda5bc12cb9a 100644
--- a/app-admin/authbind/Manifest
+++ b/app-admin/authbind/Manifest
@@ -1 +1,2 @@
DIST authbind_2.1.1.tar.gz 14407 BLAKE2B 624cb647b138006324611d00943ad78f9166e4c47821ef5b395c58eb75c1034591cb4a0549f6870fa4294f4f4ca628f03390b4539a4543a64111d33ac9cb3261 SHA512 f3a45fcf1d8d6e6762bc1cef7a1b89f211e4af56c68b4c6c5e508a2f7ee039499b8b2f11ce8aeb94822d20377d309035760fa7b58aabaa4e87417ca25811c812
+DIST authbind_2.1.2.tar.gz 15279 BLAKE2B 5f9a31c9f51c307e9ad85bf14b436e1780d0c7dc5655ad3882e9596927862be0684d0a4a43c7d2e98a0d6a0d4c2552aaaf954ce32d3e9202bf5593ce501b5962 SHA512 85020af9703f8f39194a7719c50a51d75344db9ea99ecbc83c3c6bff0852ab1ea1cbd0b9bff6a2345e08a7bef9732e36890f33af08929e36dae8215dd070cc4d
diff --git a/app-admin/authbind/authbind-2.1.2.ebuild b/app-admin/authbind/authbind-2.1.2.ebuild
new file mode 100644
index 000000000000..5c54176d277c
--- /dev/null
+++ b/app-admin/authbind/authbind-2.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Bind sockets to privileged ports without root"
+HOMEPAGE="https://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="virtual/awk"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.1-respect-flags.patch"
+)
+
+src_configure() {
+ tc-export CC LD
+
+ sed -i \
+ -e "s|^prefix=.*|prefix=/usr|" \
+ -e "s|^lib_dir=.*|lib_dir=\$(prefix)/$(get_libdir)|" \
+ -e "s|^libexec_dir=.*|libexec_dir=\$(prefix)/libexec/authbind|" \
+ -e "s|^SHARED_LDFLAGS=.*|SHARED_LDFLAGS=$(raw-ldflags)|" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|/usr/lib|/usr/libexec|' \
+ authbind-helper.8 || die "sed failed"
+}
+
+src_install() {
+ dobin authbind
+ doman authbind.1 authbind-helper.8
+
+ local major=$(awk -F= '/MAJOR=/ { print $2 }' Makefile || die)
+ ln -s libauthbind.so.* libauthbind.so.${major} || die
+ dolib.so libauthbind.so*
+
+ exeinto /usr/libexec/authbind
+ exeopts -m4755
+ doexe helper
+
+ keepdir /etc/authbind/by{addr,port,uid}
+
+ dodoc debian/changelog
+}
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
index 2a9eb5f6b84c..7e7a83e283e4 100644
--- a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
+++ b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index c1eed73..932ea60 100644
--- a/Makefile
+++ b/Makefile
@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s