summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 14:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:15:36 +0200
commitf3ab9bf3c29baae0d47d526f89befcac08a0a001 (patch)
tree5a9f710d39a5eb5e015e67fe92cc91d20f72bbc8
parentdev-python/setuptools-rust: Bump to 1.5.2 (diff)
downloadgentoo-f3ab9bf3c29baae0d47d526f89befcac08a0a001.tar.gz
gentoo-f3ab9bf3c29baae0d47d526f89befcac08a0a001.tar.bz2
gentoo-f3ab9bf3c29baae0d47d526f89befcac08a0a001.zip
dev-python/sphinx-pytest: Bump to 0.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-pytest/Manifest1
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index b3a82425fd6e..c0b125e21dc2 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-pytest-0.0.3.gh.tar.gz 5898 BLAKE2B 08fe98b3add1d76454c30a11f4d82bd04123e44fa5c28d420401014e5aef11354541781c0ba43a5d95c0c6fd35b12742ecf630005faae68125f5c6686c19ef59 SHA512 f1ee23fd5f320b5b4ac48638d509963638322374136d98516a17075e0d5b05cfa64107541c80daad424dfcd9e769a95dd5aa8d7f86d8ded214c9a3cdf901cf1f
DIST sphinx-pytest-0.0.4.gh.tar.gz 6196 BLAKE2B 24b8be165a58b15a845f076b33fb7a2525afefa7fd8bf836ac679280d271716ff02bf3adfa9b485507bc3f8a6cb91b0458a0b5bdb62bf8920c09eb20468e8949 SHA512 25bf3fafddf02aed8b2478dc2beafa251027652d03f31bbac67eb98913e359f9497a9018561aff0fdaf568ece4bcfa15705dcfa2fd3734f4db6c613b24d6a568
+DIST sphinx-pytest-0.0.5.gh.tar.gz 6228 BLAKE2B bb619ce79411a611fecf778ac095da0e7557bc419b7395efbc4dc2163699425898005fabadc083b74ac2cab8f207dcf8969f5c551c975d6354063962141c907b SHA512 e1af518cc5535ecacae612f11c7fb1200965a1999d9eb2643ba14b222fc4e93c257ef6600b37b9de4075bf3e5e703db60e7350cd5159fcf4ba21abec28bceb66
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild
new file mode 100644
index 000000000000..729dc3cc684d
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest