summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-21 07:17:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-21 08:06:43 +0200
commite158809cddb797253a03ddfadfc8a08840c6a01e (patch)
treee4e16a8b7cd4c714fb5092bb12a25baaf2765fce
parentdev-python/botocore: Bump to 1.31.8 (diff)
downloadgentoo-e158809cddb797253a03ddfadfc8a08840c6a01e.tar.gz
gentoo-e158809cddb797253a03ddfadfc8a08840c6a01e.tar.bz2
gentoo-e158809cddb797253a03ddfadfc8a08840c6a01e.zip
dev-python/boto3: Bump to 1.28.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.8.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 67cc6f8acb25..eac64a3fd286 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -13,3 +13,4 @@ DIST boto3-1.28.3.gh.tar.gz 675019 BLAKE2B 93b29307fbfec4e61dc60d28e4f20392ae2a7
DIST boto3-1.28.4.gh.tar.gz 675638 BLAKE2B e5d4cd28b61a79c54c28355003a097f7b40c5c4246c0f755886053214a50fb118c23999e86ae6afe4effdacd0c6ab6847c295d0420ab69986e84a5167278dc41 SHA512 44e89c1455c51032dae1c6745654edea2e44adf9874d726f35ed9edd1de7bc9a571d3fcfa2477b2178b7b028c33e9044745be0d66239eaeee9065cbce112aa54
DIST boto3-1.28.5.gh.tar.gz 676044 BLAKE2B b54fb3a76b9cf67a07ae95b669b6eb5a1a26aa105ea2d3a36a638099741411103f6714a50cfbd57a25b1aeeafb497d66d0324496e5986efa8aea97fc1e522d84 SHA512 437b332121384def9a16a1e83f39fd83564189421bb9d27d8f7f9f5976ca08c1089729b2ea2f9c66c200cf2f78c27c3da120d4b8fdf76b2a68f9ced2e8576c27
DIST boto3-1.28.6.gh.tar.gz 676887 BLAKE2B 997ea4b082bd427461babcbca5f5a230df0a6479359a40193698eb629be88528799c7912ff8194053f50a7d3b8c5e5e78477be5958943d22166b7f9d3f7bfb91 SHA512 67beb7986d514c8695025d5becad5e562a955b97970e26c878b80fb076d877a1479742aac74563a73569e8f5e4ccd465e564751b236147c8fc64da0855b93368
+DIST boto3-1.28.8.gh.tar.gz 677637 BLAKE2B 19f91014a394b67854ac0fc04a7b8a3e1bfb3df5a1b2f5717a739d8b2461ca049dfff7fefb9145432002742ae8613ef13a7d63b56f63bd6bddb81fb58197f625 SHA512 e6e48c601d6426b94ec648438381f0b9960af760e1a5889677124c41ffe2cff54da84b1a4be6dbfce6fcf57a5fcda74b8b9745f709cf7e1031ec4928d7c73b2d
diff --git a/dev-python/boto3/boto3-1.28.8.ebuild b/dev-python/boto3/boto3-1.28.8.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}