summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-04-05 00:35:49 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-10 09:07:30 +0200
commitce2de35c092cc58fd50d77705e000b9baaf23658 (patch)
treec0bbbd7f402bb663350d68fbab327cd4f5907c74
parentsci-geosciences/josm-bin: drop old (diff)
downloadgentoo-ce2de35c092cc58fd50d77705e000b9baaf23658.tar.gz
gentoo-ce2de35c092cc58fd50d77705e000b9baaf23658.tar.bz2
gentoo-ce2de35c092cc58fd50d77705e000b9baaf23658.zip
net-analyzer/pontos: add 24.3.2
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36112 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--net-analyzer/pontos/Manifest1
-rw-r--r--net-analyzer/pontos/pontos-24.3.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/pontos/Manifest b/net-analyzer/pontos/Manifest
index f15fee7b4ca4..4222dcb9e6c8 100644
--- a/net-analyzer/pontos/Manifest
+++ b/net-analyzer/pontos/Manifest
@@ -1 +1,2 @@
DIST pontos-24.1.2.tar.gz 379930 BLAKE2B b0c9fd02c17ca0fed7468e34264f8e41e87b4c50f6254d8d4d9ee5c7a8444a7acfbf3c113483e26831be68279d7c08bf412634fff5e3454dc0e7ec5273ddcdd6 SHA512 55fcb768d89b0fd478bbf14a435d7d42c6c9ae2ff2a834ce685e25b105ed071d156d1afbc0231d80dd8d5c844f33b648b08772a0aab943127c58f9a475f267d9
+DIST pontos-24.3.2.tar.gz 378585 BLAKE2B cb6a89a2fbfefe1b038b5886dc7a278657d36a05bab818335efd029d6320b8b60defcd73c3e94df17008ab611434898b565cb7057e1f0198113bd8a7a0600934 SHA512 4ed6a79097197da01d35a660ce13edfa028c11b082626038ea037b99b1f365b054d2c07ae841c739735da057e2d8d9fc64b63f18ad3aa941e14ff725261dde80
diff --git a/net-analyzer/pontos/pontos-24.3.2.ebuild b/net-analyzer/pontos/pontos-24.3.2.ebuild
new file mode 100644
index 000000000000..bf8315f7c568
--- /dev/null
+++ b/net-analyzer/pontos/pontos-24.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Common utilities and tools maintained by Greenbone Networks"
+HOMEPAGE="
+ https://www.greenbone.net
+ https://github.com/greenbone/pontos/
+ https://greenbone.github.io/pontos/
+"
+
+SRC_URI="https://github.com/greenbone/pontos/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/colorful-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.5.11[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.3[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.4.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/semver-2.13[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.0[${PYTHON_USEDEP}]
+ >=dev-python/shtab-1.7.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+EPYTEST_DESELECT=(
+ tests/git/test_git.py::GitExtendedTestCase::test_git_error
+ tests/version/commands/test_java.py::GetCurrentJavaVersionCommandTestCase::test_getting_version_without_version_config
+ tests/version/commands/test_java.py::VerifyJavaVersionCommandTestCase::test_verify_version_does_not_match
+)
+
+distutils_enable_tests pytest